summaryrefslogtreecommitdiff
path: root/app-arch/lrzip/lrzip-0.621.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lrzip/lrzip-0.621.ebuild')
-rw-r--r--app-arch/lrzip/lrzip-0.621.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/lrzip/lrzip-0.621.ebuild b/app-arch/lrzip/lrzip-0.621.ebuild
new file mode 100644
index 000000000000..265b8fdcddcf
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.621.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="http://ck.kolivas.org/apps/lrzip/README.md"
+SRC_URI="http://ck.kolivas.org/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-Pod-Parser"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-missing-stdarg_h.patch
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${P}"
+}
+
+src_install() {
+ default
+ rm "${D}/usr/share/doc/${P}/COPYING"
+}