summaryrefslogtreecommitdiff
path: root/app-arch/file-roller
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/Manifest2
-rw-r--r--app-arch/file-roller/file-roller-43.0.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index c5151016c8b7..429078b78738 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1,4 +1,6 @@
AUX 3.36-packages.match 664 BLAKE2B dfe72c4eb0b44b8ab589fa81c0ceaa31bc3516dee78fabe2eb48f8131b25ed75a11630ae620e70646539ef42a7c4d7d283f71ffa0fa13f64ccf164d672acd95a SHA512 154438583492c571e4c8e1c926c3cb04972255cc4d1b74f186dfbe50c9756f25e11034fe64d893fdd8f2698c8eaaebba76682a818bb6523656c7c412f8e8b614
DIST file-roller-3.42.0.tar.xz 878968 BLAKE2B af3a8bb566a0549434f20911315358dbcfb98aab17ca47adaad166f620fc3b8cfc6b60301842a55a0d35ca29f6317b16d07497de759b55bc42b61100e7357066 SHA512 ad151e1dc6546ca45550ab4c7384fb89e91dc2fc17a29437922192fefd5cbcd115d1f064e090dac48ae3fca33709a54bac918cbe03cbfd0e6fc3554913dd8322
+DIST file-roller-43.0.tar.xz 894308 BLAKE2B 85bf73947e153a3b40507e524c35f8be98a08a9ce5916e24ef44559400d7d44e4e0fbd94de8b5638fd1da967ff007894011624ccf9ad8c3481cac63aba3da6e5 SHA512 dff3d9ef5c96e5957fb4ca146072b5fdf0309299d0b1a4ab6db55e24a0652b52ba45915121db4d59d9b1ab60b4c3c64bbb56799a46a0eac5609236f4e1251837
EBUILD file-roller-3.42.0.ebuild 2244 BLAKE2B b36266be2187e3472bd06cd572982f9cb543c31192e847b91d1921b6b9c779a7d40727d8477735146ce0666fa9de68bc725d49b0d279233877c242a62bcf74d9 SHA512 e199dd0ad875976b75c249b51e86070a0fb5f0a4d9a4af93e5e78198246f609c8d65043fe0b5541823be6c7d37543f85e35664f568f67c7b22c026a7e13472a8
+EBUILD file-roller-43.0.ebuild 2515 BLAKE2B d11277cc7069f9c5f65d121ab62f012cb77a8469456491ad2069d5db01823278475a0799a8819173b489fd22abc60e532294a54aaaf8b235f40ae5a4d4f48bb1 SHA512 805ff69fbf24b4743c883de736f5e3b9706ca9c4cae5413576dbef9b3c22f228ffc25c3c75a7fb85837a198dfcf3d5b4b8ae9f784df6192c99ffa4cd3a28ff22
MISC metadata.xml 523 BLAKE2B 44d1f4c6636070d561c1d0fdb6bfaaae0f92b81608f52de78f6b5168ca717a7ab0c54ca24a8bde59cd7a7e0be96f195bd8f7eb5e53e820917fec5cf692cea7ec SHA512 79b172bc5f64b91f389c6dee90da6dca10705f07fd469b04486eb90d11988a07002233c0718c3f223df9fd63050b3fb17dc3d5f56b8923e47dfbcc231834fdc9
diff --git a/app-arch/file-roller/file-roller-43.0.ebuild b/app-arch/file-roller/file-roller-43.0.ebuild
new file mode 100644
index 000000000000..4e7c42d54342
--- /dev/null
+++ b/app-arch/file-roller/file-roller-43.0.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.22.0:3
+ >=gui-libs/libhandy-1.5.0:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+ >=dev-libs/json-glib-0.14
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-arch/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}