summaryrefslogtreecommitdiff
path: root/app-arch/createrepo_c/createrepo_c-0.21.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/createrepo_c/createrepo_c-0.21.1.ebuild')
-rw-r--r--app-arch/createrepo_c/createrepo_c-0.21.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/app-arch/createrepo_c/createrepo_c-0.21.1.ebuild b/app-arch/createrepo_c/createrepo_c-0.21.1.ebuild
deleted file mode 100644
index 7433f2a6011f..000000000000
--- a/app-arch/createrepo_c/createrepo_c-0.21.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="C implementation of createrepo"
-HOMEPAGE="https://github.com/rpm-software-management/createrepo_c"
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/rpm-software-management/createrepo_c.git"
-else
- SRC_URI="https://github.com/rpm-software-management/createrepo_c/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="legacy test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- app-arch/bzip2:=
- app-arch/drpm
- app-arch/rpm
- app-arch/xz-utils
- app-arch/zchunk
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/libxml2
- dev-libs/openssl:=
- net-misc/curl
- sys-apps/file
- sys-libs/libmodulemd
- sys-libs/zlib:=
-"
-
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DRPM=ON
- # As best I can tell, this enables distribution as a wheel. No need for this on gentoo!
- -DENABLE_PYTHON=OFF
- # Upstream enables some 'Legacy' stuff by default, let's put that behind a USE flag
- -DENABLE_LEGACY_WEAKDEPS=$(usex legacy ON OFF)
- -DWITH_LEGACY_HASHES=$(usex legacy ON OFF)
- -DWITH_LIBMODULEMD=ON
- -DWITH_ZCHUNK=ON
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- # Tests have a magic target!
- use test && cmake_src_compile tests
-}
-
-src_test() {
- "${S}"_build/tests/run_tests.sh || die "Failed to run C library tests"
-}