summaryrefslogtreecommitdiff
path: root/app-arch/cksfv/cksfv-1.3.14-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/cksfv/cksfv-1.3.14-r1.ebuild')
-rw-r--r--app-arch/cksfv/cksfv-1.3.14-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-arch/cksfv/cksfv-1.3.14-r1.ebuild b/app-arch/cksfv/cksfv-1.3.14-r1.ebuild
new file mode 100644
index 000000000000..4793e5b02741
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.14-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-linux"
+
+src_configure() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler="$(tc-getCC)" \
+ --prefix="${EPREFIX}"/usr \
+ --package-prefix="${D}" \
+ --bindir="${EPREFIX}"/usr/bin \
+ --mandir="${EPREFIX}"/usr/share/man || die
+}