summaryrefslogtreecommitdiff
path: root/app-admin/webapp-config
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config')
-rw-r--r--app-admin/webapp-config/Manifest4
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch11
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r4.ebuild91
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild8
4 files changed, 111 insertions, 3 deletions
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index 4067d9623eb7..c4c3e53d643e 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,4 +1,6 @@
+AUX webapp-config-1.55-py3.122-invalid-escape-sequence.patch 334 BLAKE2B 49579635819c92cbb47b3ed7be47d1e5dd1ad3469de1a89fe5d6ffa26e5e6290d5c090419227c9e572b348cb9297ebd7bfe33bee7e4557d55b348d68731f1aaf SHA512 0163b3cf649b54747cf8fef6b2c91017ab59c92d50c8b96fc5231491e104db20c1de968fa8fc70774f64b91d58c798467d1d0a48093cd7269cbf385aaccd49f5
DIST webapp-config-1.55.tar.bz2 72583 BLAKE2B be958dc991f0e1f6835d9c29350b7d97e3f23d52971f6013165ce59a8f4b32ac6262c9719956d1bcdbe60797f07d77910b44a749ae545c4dc15f765525144709 SHA512 44294b276fd036908438cd984ebf70433639caa18d8330bab348433b4f39ea2c42c57fa8de4f0a6198f7875429a3ef9ebe61321c288d910f9be8b3414865f438
EBUILD webapp-config-1.55-r3.ebuild 2454 BLAKE2B 8e4807d5a9daba21868277eb49f877ff9f72f6a435eaba51c32530382a1d347d6c8b2adf600a2b39f825512c7e03cd7a60600f9947b75108869fb9d696dd2671 SHA512 277d1ab115d57eef90c8af161e61be7ec424d0a4578edfadae2d9f06e7f372744d47f863cc5abc5138afca5d7d4d964e6735d6fa54e5b13e386eccd964924908
-EBUILD webapp-config-9999.ebuild 2461 BLAKE2B 190826599765147db3d87c3af1b753946baebc1c6d2ede348341188e4586fda6662a3f11cb37e5ed1a5d2f93fe995fd265c7da07ea3f295b4c4502520f872b63 SHA512 a6a166671465821d6fb6ccbd27e0e70e2efccb61a7117b166e063e9afa91f2c1140e380b02fd88fa1cdf8611525c0679b9d6d0ea61b41b44e3733bda43fc5b88
+EBUILD webapp-config-1.55-r4.ebuild 2546 BLAKE2B 22c3c0fbce94c3844327e26c1892b7ca8a68dc35ba35d2f9c7a9d80489570edeeaeb37137be327279dca9e1564a4e7f94a14b5e5e3b8b66329f3d8872bb39409 SHA512 b631235e96df3f31d09c0643982105ba3016f0073b614bc298b5216f8e23735cdd149ec60082b5ef7c5e6fece10d6b9e6abfe7291022fb2ea1dd33bb876d5b90
+EBUILD webapp-config-9999.ebuild 2546 BLAKE2B 22c3c0fbce94c3844327e26c1892b7ca8a68dc35ba35d2f9c7a9d80489570edeeaeb37137be327279dca9e1564a4e7f94a14b5e5e3b8b66329f3d8872bb39409 SHA512 b631235e96df3f31d09c0643982105ba3016f0073b614bc298b5216f8e23735cdd149ec60082b5ef7c5e6fece10d6b9e6abfe7291022fb2ea1dd33bb876d5b90
MISC metadata.xml 448 BLAKE2B 14bff33f87640b065d72b7bd98742c602e1cd30be80cde6bbc5bd923cb8529f55e4296e83e630e55a9c8342da063dc3762f515bccd2614fc50d68770260fd727 SHA512 20db75371335720225afe0111925fe6ba3979448987a27459786a4490b862073ac23374ba29c218e523ea465fb811c7686d5a36e073a35a2a2b2c4521b6961f2
diff --git a/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch b/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
new file mode 100644
index 000000000000..cb1ba1a8593e
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
@@ -0,0 +1,11 @@
+--- a/WebappConfig/protect.py
++++ b/WebappConfig/protect.py
+@@ -78,7 +78,7 @@
+
+ numbers = []
+ prefix = self.protect_prefix
+- rep = re.compile(prefix.replace('.','\.') + '(\d{4})_')
++ rep = re.compile(prefix.replace('.',r'\.') + r'(\d{4})_')
+
+ for i in entries:
+ rem = rep.match(i)
diff --git a/app-admin/webapp-config/webapp-config-1.55-r4.ebuild b/app-admin/webapp-config/webapp-config-1.55-r4.ebuild
new file mode 100644
index 000000000000..cc2e8028b578
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.55-r4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 prefix
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+portage"
+
+DEPEND="app-text/xmlto
+ sys-apps/gentoo-functions"
+RDEPEND="
+ portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
+)
+
+python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
+ distutils-r1_python_prepare_all
+ eprefixify WebappConfig/eprefix.py config/webapp-config
+}
+
+python_compile_all() {
+ emake -C doc/
+}
+
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc AUTHORS
+ doman doc/*.[58]
+}
+
+pkg_postinst() {
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+}
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 76caefb23e6d..cc2e8028b578 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 prefix
@@ -29,6 +29,10 @@ DEPEND="app-text/xmlto
RDEPEND="
portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
+)
+
python_prepare_all() {
# make the source from svn mirror the one in the tarball
if [[ ${PV} == 9999* ]]; then