summaryrefslogtreecommitdiff
path: root/app-admin/verynice/verynice-1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/verynice/verynice-1.1-r2.ebuild')
-rw-r--r--app-admin/verynice/verynice-1.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/verynice/verynice-1.1-r2.ebuild b/app-admin/verynice/verynice-1.1-r2.ebuild
new file mode 100644
index 000000000000..e9dc02e399c0
--- /dev/null
+++ b/app-admin/verynice/verynice-1.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit epatch systemd toolchain-funcs
+
+DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
+HOMEPAGE="https://web.archive.org/web/2010033109/http://thermal.cnde.iastate.edu/~sdh4/verynice/"
+SRC_URI="http://thermal.cnde.iastate.edu/~sdh4/verynice/down/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr
+}
+
+src_install(){
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr VERSION=${PVR} install
+ doinitd "${FILESDIR}"/verynice
+ systemd_dounit "${FILESDIR}"/verynice.service
+}