summaryrefslogtreecommitdiff
path: root/app-admin/terraform/terraform-0.12.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/terraform/terraform-0.12.11.ebuild')
-rw-r--r--app-admin/terraform/terraform-0.12.11.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/app-admin/terraform/terraform-0.12.11.ebuild b/app-admin/terraform/terraform-0.12.11.ebuild
deleted file mode 100644
index effc18ec2234..000000000000
--- a/app-admin/terraform/terraform-0.12.11.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit golang-base go-module
-
-DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
-HOMEPAGE="https://www.terraform.io/"
-
-EGO_PN="github.com/hashicorp/${PN}"
-SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 imagemagick ISC JSON MIT MIT-with-advertising MPL-2.0 unicode"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
-
-DOCS=( {README,CHANGELOG}.md )
-
-src_compile() {
- GOCACHE="${T}/go-cache" go build \
- -work -o "bin/${PN}" ./ || die
-}
-
-src_install() {
- dobin bin/terraform
-
- einstalldocs
-}
-
-pkg_postinst() {
- elog "If you would like to install shell completions please run:"
- elog " terraform -install-autocomplete"
-}