summaryrefslogtreecommitdiff
path: root/app-admin/tenshi
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/tenshi')
-rw-r--r--app-admin/tenshi/Manifest2
-rw-r--r--app-admin/tenshi/tenshi-0.18.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/tenshi/Manifest b/app-admin/tenshi/Manifest
index 7d973e3476b5..8f2042a8fc3d 100644
--- a/app-admin/tenshi/Manifest
+++ b/app-admin/tenshi/Manifest
@@ -1,3 +1,5 @@
DIST tenshi-0.17.tar.gz 24597 BLAKE2B 846128e65b1a2d2a3bc5edecc9356069f44d9c13757771ec7fc5c31063d8aeb9403d447dbb088d2aa7d05d3b086ac6c569cd24a05c336225540b3baa10e79bb7 SHA512 2ca93ceaab0843c321fa69d8ba1c7b31eaf809cac4348c98327ddd9ab72df4d5ff00d6b4edeb19a9f02e154161988e0c2284248fd0e84d2b42dd82fdbaac1a78
+DIST tenshi-0.18.tar.gz 25299 BLAKE2B a8aa6b1c88c85a38dacf27755da82b4a5cb8305faaf9c39b3bc877e6e13474987d32043145e2e14ec8fbb5f6450c7b8c9abae6762c2dcb31c107960d353a5de9 SHA512 a9f08600efb5c36630d73b0ae5c596948a7cdaec43b967b7c7d4f04fba8f2a698b71faea240391f45f1fc86f168722103f3b0be198b3853e2487256cbad2aac0
EBUILD tenshi-0.17-r1.ebuild 1064 BLAKE2B 750bc9a70e15d2b99686706222cf48197cf26bda5980b24bc6af9cd3d27feba01bbbb3efe1e53ddf700b67c743e8bd040bd64f05b67f91e7ce89a5d268cf6599 SHA512 3240e54667f6f9a662ce101533b0dc20ec4512ee70a441882a0013269909bd4897e39509de3ccb9e8cd44b46aa8f075d16da036f5c0331223dfa69039fe49a86
+EBUILD tenshi-0.18.ebuild 1067 BLAKE2B 67ace5f05f1eb751b75cd67d0a74299c8e2754d26f6bb2de5d6745d38baf36fe298b51f8d7b808520e51d54aea32820bb8ed17355138d45c6ea90b52fcd18229 SHA512 5556e6cd0acf1bdee37d4fba86bebd3760b81b7fab2020291affdb226245ee38724117a0437bfda44748574b221fe5fff81367cc30fb77671e76b83e1e6dff9d
MISC metadata.xml 256 BLAKE2B 7e70afe7b638aa8ea509dbeaf121863185bec82e00a390594227fa978ff3844beec20e6f890b1ededec90e9ee85f4324414f274ed99663923023901cab72c764 SHA512 64f3cc3f5a9caedd47a5760ed1165cb5608d61c0e1d1c10d12520ef7327d5546d669ead8b5aab93be9e202d1d68c57765e605ea8ba5405d425b7f826d83f9032
diff --git a/app-admin/tenshi/tenshi-0.18.ebuild b/app-admin/tenshi/tenshi-0.18.ebuild
new file mode 100644
index 000000000000..d5975a92a7ff
--- /dev/null
+++ b/app-admin/tenshi/tenshi-0.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Log parsing and notification program"
+HOMEPAGE="https://inversepath.com/tenshi.html https://github.com/f-secure-foundry/tenshi"
+SRC_URI="https://github.com/f-secure-foundry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ acct-group/tenshi
+ acct-user/tenshi
+ dev-lang/perl
+ dev-perl/IO-BufferedSelect
+ sys-apps/coreutils
+"
+
+src_prepare() {
+ default
+
+ # Fix for bug #241254
+ sed 's:^docdir =.*:docdir = /usr/share/doc/${PF}:' -i Makefile || die "docdir substitution failed"
+}
+
+src_install() {
+ default
+
+ doman tenshi.8
+ keepdir /var/lib/tenshi
+ newinitd tenshi.openrc-init tenshi
+}
+
+pkg_postinst() {
+ ewarn "The sample config installed to ${ROOT}/etc/tenshi/tenshi.conf"
+ ewarn "monitors /var/log/messages which, by default, can not be read"
+ ewarn "by the tenshi user. Make sure that the tenshi user has read"
+ ewarn "permission on all the files that you want tenshi to monitor."
+}