summaryrefslogtreecommitdiff
path: root/app-admin/salt/salt-3004.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/salt/salt-3004.2-r2.ebuild')
-rw-r--r--app-admin/salt/salt-3004.2-r2.ebuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/app-admin/salt/salt-3004.2-r2.ebuild b/app-admin/salt/salt-3004.2-r2.ebuild
index 1e3ce475d192..c420cc03e20f 100644
--- a/app-admin/salt/salt-3004.2-r2.ebuild
+++ b/app-admin/salt/salt-3004.2-r2.ebuild
@@ -45,7 +45,7 @@ RDEPEND="
ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
<dev-python/importlib_metadata-5[${PYTHON_USEDEP}]
libvirt? (
- $(python_gen_cond_dep 'dev-python/libvirt-python[${PYTHON_USEDEP}]' python3_8)
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
)
openssl? (
dev-libs/openssl:0=[-bindist(-)]
@@ -65,10 +65,10 @@ RDEPEND="
redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
selinux? ( sec-policy/selinux-salt )
nova? (
- $(python_gen_cond_dep '>=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}]' python3_8)
+ >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}]
)
neutron? (
- $(python_gen_cond_dep '>=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}]' python3_8)
+ >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}]
)
gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
@@ -193,18 +193,5 @@ python_test() {
}
pkg_postinst() {
- if use python_targets_python3_8; then
- if use nova; then
- ewarn "Salt's nova functionality will not work with python3.8 since"
- ewarn "dev-python/python-novaclient does not support it yet"
- fi
- if use neutron; then
- ewarn "Salt's neutron functionality will not work with python3.8 since"
- ewarn "dev-python/python-neutronclient does not support it yet"
- fi
- if use libvirt; then
- ewarn "Salt's libvirt functionality will not work with python3.8 since"
- ewarn "dev-python/libvirt-python does not support it yet"
- fi
- fi
+ :
}