summaryrefslogtreecommitdiff
path: root/app-admin/rex/rex-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/rex/rex-9999.ebuild')
-rw-r--r--app-admin/rex/rex-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-admin/rex/rex-9999.ebuild b/app-admin/rex/rex-9999.ebuild
index 5cc3866dba75..02f767b58c6f 100644
--- a/app-admin/rex/rex-9999.ebuild
+++ b/app-admin/rex/rex-9999.ebuild
@@ -18,7 +18,7 @@ else
DIST_NAME=Rex
KEYWORDS="~amd64 ~x86"
fi
-inherit perl-module ${VCS_ECLASS}
+inherit bash-completion-r1 perl-module ${VCS_ECLASS}
DESCRIPTION="(R)?ex, the friendly automation framework"
@@ -183,3 +183,12 @@ src_prepare() {
cd "${S}" || die "Can't enter build dir"
perl-module_src_prepare
}
+
+src_install() {
+ newbashcomp "share/${PN}-tab-completion.bash" "${PN}"
+
+ insinto /usr/share/zsh/site-functions
+ newins "share/${PN}-tab-completion.zsh" "_${PN}"
+
+ perl-module_src_install
+}