summaryrefslogtreecommitdiff
path: root/app-admin/pydf/pydf-12-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pydf/pydf-12-r2.ebuild')
-rw-r--r--app-admin/pydf/pydf-12-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/pydf/pydf-12-r2.ebuild b/app-admin/pydf/pydf-12-r2.ebuild
new file mode 100644
index 000000000000..c8a37dd8e90b
--- /dev/null
+++ b/app-admin/pydf/pydf-12-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit python-r1
+
+DESCRIPTION="Enhanced df with colors"
+HOMEPAGE="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/"
+SRC_URI="http://kassiopeia.juls.savba.sk/~garabik/software/pydf/${PN}_${PV}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s#/etc/pydfrc#${EPREFIX}/etc/pydfrc#" "${PN}" || die
+}
+
+src_install() {
+ python_foreach_impl python_doscript "${PN}"
+ insinto /etc
+ doins "${PN}rc"
+ doman "${PN}.1"
+ einstalldocs
+}