summaryrefslogtreecommitdiff
path: root/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild')
-rw-r--r--app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild b/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild
new file mode 100644
index 000000000000..9cdb4c9c0fd6
--- /dev/null
+++ b/app-admin/procinfo-ng/procinfo-ng-2.0.304-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Completely rewrite of the old system monitoring app procinfo"
+HOMEPAGE="https://sourceforge.net/projects/procinfo-ng/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE=""
+
+RDEPEND="
+ sys-libs/ncurses
+ !app-admin/procinfo"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-man.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ # removing -s flag as portage does the stripping part and add support
+ # for custom LDFLAGS. Plus correct for --as-needed
+ sed \
+ -e 's:-s -lncurses:${LDFLAGS}:' \
+ -i configure.in || die "sed configure.in failed"
+ eautoreconf
+}
+
+src_compile() {
+ emake LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
+}