summaryrefslogtreecommitdiff
path: root/app-admin/paxtest
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/paxtest')
-rw-r--r--app-admin/paxtest/Manifest4
-rw-r--r--app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch20
-rw-r--r--app-admin/paxtest/metadata.xml27
-rw-r--r--app-admin/paxtest/paxtest-0.9.15-r1.ebuild44
4 files changed, 95 insertions, 0 deletions
diff --git a/app-admin/paxtest/Manifest b/app-admin/paxtest/Manifest
new file mode 100644
index 000000000000..350672a0525a
--- /dev/null
+++ b/app-admin/paxtest/Manifest
@@ -0,0 +1,4 @@
+AUX paxtest-0.9.13-Makefile.patch 508 BLAKE2B dddbe4e9c2cf761c4abcff5f2d708a90750a0f11dc685cd99d162ef4a90a3beaa9a3c12f01994ff34202ba33b8a04554c59213d4bbcb48491528ca957c443c10 SHA512 ed28fc2d852ef0f4da5268c8f66e9a5c5f2b75509cb67627ab1afbd9c3b89609a0e88686cb317f3e6e48874e02d5593b7a7661160ef849859cb9e77be375a6fc
+DIST paxtest-0.9.15.tar.gz 37929 BLAKE2B 0b0290212fa27b8f27bea62c209423b6ea57e9c3e7d972fd069f0213b3963eb7a65921c669ac402b5d83f6556ba9ede90375b58f0f7ec6daf6cc3a293372edf5 SHA512 e152f5ada943f69b3745b51ac6d80f35a4c1aff777e93360287ef18b117d07861216d9d0d2075d2511d33e2cb4ea07168bb9ff2f00e79de6060e546b6806c487
+EBUILD paxtest-0.9.15-r1.ebuild 942 BLAKE2B 87d557f82a0e54ddc70f1505c3b693f31beb307afb8603c67f70cf2bbfed2d788180f84358ef430a083faa8e2a76c98d77166316cd6f29962442e5aa628d1775 SHA512 c9bf34adbd5935fd323bc20fbf8e53a0c3fa436b0fe38cb1d347de9612a1b7019f26ce99afb12a4e66c9562e123f78fe52e68068d9f9c9b4893826c841d05199
+MISC metadata.xml 1140 BLAKE2B 4ba22a2a46b61986421373ff6a401f6c056bdb47b89b38552faa0e7b761b1bc171f253f238b59659183678590632d1f414f1108df2ad6ece17ffdb8eb32d45c1 SHA512 8abd1878f49a3e0fb560c0547555140f369d419b07ac05def097deaf386a162a4ce9fc7263dcf417e2909985900a8e01f517fcc3282c93c156c3339fe6a9f6ed
diff --git a/app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch b/app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch
new file mode 100644
index 000000000000..4dd4831eb453
--- /dev/null
+++ b/app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -52,12 +52,14 @@
+ endif
+
+ # for some reason the .c files need it, else GNU_STACK=RWE
+-OPT_FLAGS := -O2 $(ASFLAGS)
++# Gentoo's CFLAGS should be honored
++OPT_FLAGS := $(CFLAGS) $(ASFLAGS)
+ PTHREAD := -lpthread
+ # define stripping of binaries/libs here, or set these on make's commandline,
+ # else you'll loose the chpax flags!
+-LDFLAGS :=
+-SHLDFLAGS :=
++# Gentoo's LDFLAGS should be honored
++LDFLAGS := $(LDFLAGS)
++SHLDFLAGS := $(LDFLAGS)
+ ifndef RUNDIR
+ RUNDIR := .
+ endif
diff --git a/app-admin/paxtest/metadata.xml b/app-admin/paxtest/metadata.xml
new file mode 100644
index 000000000000..78cd07dfc29d
--- /dev/null
+++ b/app-admin/paxtest/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>hardened@gentoo.org</email>
+ <name>Gentoo Hardened</name>
+ </maintainer>
+ <longdescription>Test suite for the PaX kernel patch
+ PaX is a Linux kernel patch which adds much stricter control on how memory
+ is being used by applications. A normal Linux kernel leaves the control to the
+ application and does not implement any enforcement. Especially buffer overflow
+ attacks benefit from the absense of kernel enforced memory control. PaX tries
+ to do its best to enforce this control of memory used by applications, thereby
+ making it harder to succesfully exploit buffer overflows.
+
+ Furthermore, it adds several randomisations, which also make it harder for
+ buffer overflows to succeed.
+
+ The test programs test all this functionality, but not all PaX functionality
+ is covered.
+
+ For more information about PaX, see http://pageexec.virtualave.net/.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/paxtest/paxtest-0.9.15-r1.ebuild b/app-admin/paxtest/paxtest-0.9.15-r1.ebuild
new file mode 100644
index 000000000000..4fe8a445c276
--- /dev/null
+++ b/app-admin/paxtest/paxtest-0.9.15-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="PaX regression test suite"
+HOMEPAGE="https://pax.grsecurity.net"
+SRC_URI="https://grsecurity.net/~spender/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/paxctl"
+
+# EI_PAX flags are not strip safe.
+RESTRICT="strip"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.13-Makefile.patch"
+)
+
+src_prepare() {
+ mv Makefile.psm Makefile
+ default
+ sed -i "s/^CC := gcc/CC := $(tc-getCC)/" Makefile
+ sed -i "s/^LD := ld/LD := $(tc-getLD)/" Makefile
+}
+
+src_compile() {
+ emake RUNDIR=/usr/$(get_libdir)/paxtest || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR=/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest install || die
+
+ newman debian/manpage.1.ex paxtest.1 || die
+ dodoc ChangeLog README || die
+}