summaryrefslogtreecommitdiff
path: root/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild')
-rw-r--r--app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild
new file mode 100644
index 000000000000..b76e25b4baf5
--- /dev/null
+++ b/app-admin/ngxtop/ngxtop-0.0.3_pre141201-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="real-time metrics for nginx server (and others)"
+HOMEPAGE="https://github.com/lebinh/ngxtop"
+#SRC_URI="https://github.com/lebinh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0.2-py3.patch )
+
+distutils_enable_tests pytest