summaryrefslogtreecommitdiff
path: root/app-admin/kubectx/kubectx-0.6.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/kubectx/kubectx-0.6.1.ebuild')
-rw-r--r--app-admin/kubectx/kubectx-0.6.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/kubectx/kubectx-0.6.1.ebuild b/app-admin/kubectx/kubectx-0.6.1.ebuild
new file mode 100644
index 000000000000..bcdb869a0ef6
--- /dev/null
+++ b/app-admin/kubectx/kubectx-0.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vcs-snapshot bash-completion-r1
+
+DESCRIPTION="Fast way to switch between clusters and namespaces in kubectl"
+HOMEPAGE="https://github.com/ahmetb/kubectx"
+SRC_URI="https://github.com/ahmetb/kubectx/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-cluster/kubectl"
+
+src_install() {
+ dobin kubectx kubens
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/kubectx.zsh _kubectx
+ newins completion/kubens.zsh _kubens
+
+ newbashcomp completion/kubectx.bash kubectx
+ newbashcomp completion/kubens.bash kubens
+}