summaryrefslogtreecommitdiff
path: root/app-admin/gkrellm/gkrellm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gkrellm/gkrellm-9999.ebuild')
-rw-r--r--app-admin/gkrellm/gkrellm-9999.ebuild30
1 files changed, 14 insertions, 16 deletions
diff --git a/app-admin/gkrellm/gkrellm-9999.ebuild b/app-admin/gkrellm/gkrellm-9999.ebuild
index caea7327cbef..18b1fce7cd92 100644
--- a/app-admin/gkrellm/gkrellm-9999.ebuild
+++ b/app-admin/gkrellm/gkrellm-9999.ebuild
@@ -1,19 +1,17 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit desktop systemd toolchain-funcs
-MY_P="${P/_/-}"
-
DESCRIPTION="Single process stack of various system monitors"
HOMEPAGE="http://www.gkrellm.net/"
if [[ "${PV}" == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://git.srcbox.net/gkrellm/gkrellm.git"
else
- SRC_URI="http://gkrellm.srcbox.net/${MY_P}.tar.bz2"
+ SRC_URI="http://gkrellm.srcbox.net/releases/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-3+"
@@ -41,22 +39,22 @@ RDEPEND="
x11-libs/libSM
x11-libs/libX11
x11-libs/pango
- )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-BDEPEND="
- virtual/pkgconfig
+ )
"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ nls? ( sys-devel/gettext )
+"
+
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-2.3.5-config.patch
- "${FILESDIR}"/${PN}-2.3.5-width.patch
- "${FILESDIR}"/${PN}-2.3.5-sansfont.patch
+ "${FILESDIR}/${PN}-2.3.5-config.patch"
+ "${FILESDIR}/${PN}-2.3.5-width.patch"
+ "${FILESDIR}/${PN}-2.3.5-sansfont.patch"
)
-S="${WORKDIR}/${MY_P}"
-
DOCS=( Changelog CREDITS README )
pkg_pretend() {