summaryrefslogtreecommitdiff
path: root/app-admin/gixy/gixy-0.1.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/gixy/gixy-0.1.20.ebuild')
-rw-r--r--app-admin/gixy/gixy-0.1.20.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/app-admin/gixy/gixy-0.1.20.ebuild b/app-admin/gixy/gixy-0.1.20.ebuild
deleted file mode 100644
index a8d8b10d8ad4..000000000000
--- a/app-admin/gixy/gixy-0.1.20.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Nginx configuration static analyzer"
-HOMEPAGE="https://github.com/yandex/gixy"
-# Use GitHub source insted PyPi to get tarball with tests
-SRC_URI="https://github.com/yandex/gixy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
- >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/configargparse-0.11.0[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.1.0[${PYTHON_USEDEP}]"
-
-distutils_enable_tests nose
-
-python_prepare_all() {
- sed -i -e "/argparse/d" setup.py || die
- distutils-r1_python_prepare_all
-}