summaryrefslogtreecommitdiff
path: root/app-admin/exo/exo-1.5.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/exo/exo-1.5.1.ebuild')
-rw-r--r--app-admin/exo/exo-1.5.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/exo/exo-1.5.1.ebuild b/app-admin/exo/exo-1.5.1.ebuild
new file mode 100644
index 000000000000..ebb329b957ff
--- /dev/null
+++ b/app-admin/exo/exo-1.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://exoscale.github.io/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+}