summaryrefslogtreecommitdiff
path: root/app-admin/emacs-updater
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/emacs-updater')
-rw-r--r--app-admin/emacs-updater/Manifest3
-rw-r--r--app-admin/emacs-updater/emacs-updater-1.15.ebuild37
-rw-r--r--app-admin/emacs-updater/metadata.xml8
3 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/emacs-updater/Manifest b/app-admin/emacs-updater/Manifest
new file mode 100644
index 000000000000..15a4aef100ea
--- /dev/null
+++ b/app-admin/emacs-updater/Manifest
@@ -0,0 +1,3 @@
+DIST emacs-updater-1.15.tar.xz 7020 BLAKE2B bb35103b328a57dcaeb11c258bddbd3a08141d1e245ac4943c7a5a8b815440db0cd06eaac01ad2a00e6e2aa0d23311d774d190fd761be66514856077b3c4e296 SHA512 8cc7dd3e0e28ae71030c7c5f29d54f24e12adcbd0615f3c598ad262bd233f028c2424c277aac7dff7b4201a2ac24bfab0e05d1fdc07edcee2c184a733f699b8a
+EBUILD emacs-updater-1.15.ebuild 969 BLAKE2B 9b77db09396e09d9c80f7f49a46bae2e202b0cfd1b43ff96f7cb762c6255565967265c6cafc24d5d6859195c77a6047eea70a5d437985fb5333a811f176148c9 SHA512 30e75f83c944a730a58ad8dbc36f640fe1e87d378db2ba4465678737f77e8f29156eb50b0ac6b07ba084f0b13d5ff216fb90d0db8a28301b81c4fdaaa03bf684
+MISC metadata.xml 259 BLAKE2B 3e6f3a8d36eff69f3dc47c089b6b31bbd853db73e3ec9e6534f068caacea5f1651547da161de8ecd712c6937cde45f5a4a39ab5025633f09c791e5a4f498a429 SHA512 9a5c456aae7919a4cdbb10b67a27c232daf2ec6db4202e04ba6d5873242fc982a659410443dd6fb4498d42af00b495acc51a6a2cbe12aeab91b585dfac7233a3
diff --git a/app-admin/emacs-updater/emacs-updater-1.15.ebuild b/app-admin/emacs-updater/emacs-updater-1.15.ebuild
new file mode 100644
index 000000000000..5f285a56dcac
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-1.15.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="|| ( sys-apps/util-linux app-misc/getopt )"
+RDEPEND="${DEPEND}
+ >=app-portage/portage-utils-0.3
+ virtual/emacs"
+
+src_prepare() {
+ default
+
+ if ! has_version sys-apps/util-linux; then
+ # BSD ships a dumb getopt(1), so use getopt-long instead
+ sed -i -e '/^GETOPT=/s/getopt/&-long/' emacs-updater || die
+ fi
+
+ if [[ -n ${EPREFIX} ]]; then
+ sed -i -e "1s:/:${EPREFIX%/}/:" \
+ -e "s:^\([[:upper:]]*=\)/:\1${EPREFIX%/}/:" \
+ emacs-updater || die
+ fi
+}
+
+src_install() {
+ dosbin emacs-updater
+ doman emacs-updater.8
+}
diff --git a/app-admin/emacs-updater/metadata.xml b/app-admin/emacs-updater/metadata.xml
new file mode 100644
index 000000000000..c438baf3b326
--- /dev/null
+++ b/app-admin/emacs-updater/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+</pkgmetadata>