summaryrefslogtreecommitdiff
path: root/app-admin/cdist
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cdist')
-rw-r--r--app-admin/cdist/Manifest4
-rw-r--r--app-admin/cdist/cdist-4.10.6.ebuild2
-rw-r--r--app-admin/cdist/cdist-5.1.3.ebuild24
3 files changed, 28 insertions, 2 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
index 1a68ce62a265..b9fc0327ffa1 100644
--- a/app-admin/cdist/Manifest
+++ b/app-admin/cdist/Manifest
@@ -1,3 +1,5 @@
DIST cdist-4.10.6.tar.gz 676651 BLAKE2B 107b60c8890ede0bfa9f741375cc1705946b2d6be9caa4ae41c2ba155097b64e451474218ae9d5a8e2aa2511908869e8a5aa24fe15f0d41a50c8775d037a7eb3 SHA512 558fbe242a24fcd204a0b2519c9ad73405fe20466600af3635c6a5029641c4aec4315be99af0d5d9c1920aaadfe96942ffab94133c48675655ea8107fc8af90c
-EBUILD cdist-4.10.6.ebuild 593 BLAKE2B ce5fa56d967e7026a56a0eaffcd601bfdb40775cb7fa4a2078523d625be09aff694cb8b574330066bac1a5bcb2bf69d18028f768043a557dc23e8d3027129d55 SHA512 e1c557b71f4d1ee046117411edcc932c886b3e72f64adfc331a621ab4e279c91f954f6c68fdfa25d788ebf889085ad5122143068cb45584af34bfd5caef5f498
+DIST cdist-5.1.3.tar.gz 915245 BLAKE2B 5fce58f6fcbd48852e1c0c5568b72c360e74fd49b5321e2aedfdc8e48fd090cbdd7bab87a94e76d087f04f5a706bf2c7b1bebdc5a80867e26d8cc6e28afdeab3 SHA512 8330a5af80dfc07da722675ae1d402ebae4ba0aada451a02d782365d68d1d43a643609f3326f5ed793d2902838ee29071c0255c9d8a9d38c1e8a7c92a24cef46
+EBUILD cdist-4.10.6.ebuild 594 BLAKE2B b4eacbd2736994e8119709f83dc059ef2f5b14b08916c1f02f715db051ad3511e79bcad5666cb0b80b06eb70c13095e224716429c3c02c6a51bfc49f41ebbb42 SHA512 3b50d7c613d08f3502f055ce6d81338dd97610560375065eb65d8721a3a43bb6f6ee93971059c0920bbb02c82b40036b233fddad643c6ba7efb24d6f649fb27d
+EBUILD cdist-5.1.3.ebuild 594 BLAKE2B b4eacbd2736994e8119709f83dc059ef2f5b14b08916c1f02f715db051ad3511e79bcad5666cb0b80b06eb70c13095e224716429c3c02c6a51bfc49f41ebbb42 SHA512 3b50d7c613d08f3502f055ce6d81338dd97610560375065eb65d8721a3a43bb6f6ee93971059c0920bbb02c82b40036b233fddad643c6ba7efb24d6f649fb27d
MISC metadata.xml 443 BLAKE2B 2742628c4f58fc21f1fca78752bce1e6275ec34ca7aa547a39d8a11cf3c7d9c149030078a55383f706053fa3cd70f071d5d5c571f3b009e941cbbc2c29b6c21a SHA512 5d1dbb6742101c7b89662f3edba9d3eb7da595611fbb613a1da1482e76cbf563fdf5fbf227471ca4c90e5a96d62c65433beaf9b90bbc716c7614ea5fe6b5063a
diff --git a/app-admin/cdist/cdist-4.10.6.ebuild b/app-admin/cdist/cdist-4.10.6.ebuild
index d9e2be9d9d92..5d7033af2783 100644
--- a/app-admin/cdist/cdist-4.10.6.ebuild
+++ b/app-admin/cdist/cdist-4.10.6.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="A usable configuration management system"
HOMEPAGE="https://www.nico.schottelius.org/software/cdist/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="GPL-3"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
diff --git a/app-admin/cdist/cdist-5.1.3.ebuild b/app-admin/cdist/cdist-5.1.3.ebuild
new file mode 100644
index 000000000000..5d7033af2783
--- /dev/null
+++ b/app-admin/cdist/cdist-5.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}