summaryrefslogtreecommitdiff
path: root/app-admin/awscli
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest2
-rw-r--r--app-admin/awscli/awscli-1.36.32.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 96bf7c116a4f..7ceeeaa49950 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,7 +1,9 @@
DIST aws-cli-1.36.22.gh.tar.gz 2853997 BLAKE2B a9f309c157595edd37e87834e7b67c16c04edb8f9f2381e8dd2335cc932b2071f7cfd24ca4abd16100ef1de21adb7f502af911d71c20459e0321a9375a49ec0e SHA512 05ee5d22f5f552ba0e7eaf4a1a88bcb3a2cb8db30315fdbf04d9c9c1c69b07ae3a8727e1dca1b154d9dad4bf89aa5950c0f369a965f92ec99f7e0251665f13eb
DIST aws-cli-1.36.27.gh.tar.gz 2874317 BLAKE2B 5f696b14ba47e6b9b0150e600d7f3241d5bebc1c66e848239221db74dada3c358c5eae795e9d3988383ac431f449729c4226e17724d54d5a6b9531e046c15810 SHA512 0e8dd2bb6dc086f3ff29931c1f41778f6c25e3a173def142f12b6e57fac6edd0df0cd588bc522045561afc44827b8fd2a0bcd582bb72ee01727d22bd0b34a3cc
DIST aws-cli-1.36.31.gh.tar.gz 2876521 BLAKE2B 6ba90d3852b25608bb908b3853bff3de7c0fb94ee6177177abefab16993e7cbd85dec62db8e453c4de2e846bda7ab46efb8e71f6bbb28a458e5bf7cbd53cdc7f SHA512 a0b7de55c3bd518f61d112fa9bd710636ba0118322ceedb959cd2f814fb6dd983516717a3a0c6b3af3a507365da2b73553ede4e0e6dd691601fdbe8e90c0fa68
+DIST aws-cli-1.36.32.gh.tar.gz 2877216 BLAKE2B 41e5033374cb39d3ee1cb871d3b01a67944dc397ea21e7069acd7b8059c8a1aa04698d78c0090a75bf00b8c4e55d961e34b47f896d7e678d6bfac9d417154826 SHA512 b02b9ae9e92c7fc2d3e46e7d1aea83ce23ab3e40d8f908e68e4e6afd4b58e8222caeea34a48ce934d8494290e1e0279dd4b49305c6d4dc73216944d0dec264db
EBUILD awscli-1.36.22.ebuild 3179 BLAKE2B b08625a4293f13915f076119919380f482a550799f0b4a8ba37f413fb23314bd5f8ee153658520d17560e91fc464ffdb0bc61f444dda692627baa6ddc80fd97b SHA512 2acdae36bf23c5c4c4bf23ca22ef04df62e76f08fc3ecc9acf6ba28bd4c6b9bd325f301123c9cb5694b62991cf41bfcff797ce4c72ae07e0d7c490df02adae4c
EBUILD awscli-1.36.27.ebuild 3186 BLAKE2B 63a0fb498273465997fdf8010dcec351d473545febb8aaf2c222c3176a00f0cce5edadbfbc778689949142466c05e371a017c07a54ce30deb7bd7ca86cdb1e82 SHA512 2db712c340a0d13e4f89a8ca4599cb89f83d11d519b2f90f1dcf72e903830d70ae31efbed50a958b98655e24327cc027c0c945bc061f9de7c8fbf4d45f2fa625
EBUILD awscli-1.36.31.ebuild 3186 BLAKE2B 63a0fb498273465997fdf8010dcec351d473545febb8aaf2c222c3176a00f0cce5edadbfbc778689949142466c05e371a017c07a54ce30deb7bd7ca86cdb1e82 SHA512 2db712c340a0d13e4f89a8ca4599cb89f83d11d519b2f90f1dcf72e903830d70ae31efbed50a958b98655e24327cc027c0c945bc061f9de7c8fbf4d45f2fa625
+EBUILD awscli-1.36.32.ebuild 3186 BLAKE2B 65b27edf9a080dad4a72a8fb6426840ffb39c57c020d93482c79003438b4b3523e24526c27bc4a186630245535f796454c03f299604eb03707d777cd4bd77099 SHA512 5fac354f14a164645961d81b8731b1a03cde670d69c600cae21b89245564d6f566652fcb5d7b5eab3012de676a8e7da85c424bb823a53a570f988b5b4b9b3e70
MISC metadata.xml 385 BLAKE2B 5accfb180a91179cc6df539d42d1de06be3ebfec73f3edb719f5d59576103b9a8cb0c7c524c1042630e0cf99f068939a19f04c7b1b4a2acf9e072369df80d913 SHA512 ccb3d516326c5dbdf53068372ce25baecc137d21a04516374362212b969cc928dacbf743b4953da33f28482905798f069d09d19c88d9913f2b32648db25115ab
diff --git a/app-admin/awscli/awscli-1.36.32.ebuild b/app-admin/awscli/awscli-1.36.32.ebuild
new file mode 100644
index 000000000000..cffe1be806db
--- /dev/null
+++ b/app-admin/awscli/awscli-1.36.32.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).(z+59)
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(( $(ver_cut 3-) + 59 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}