summaryrefslogtreecommitdiff
path: root/app-admin/ansible/ansible-4.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible/ansible-4.8.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-4.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-4.8.0.ebuild b/app-admin/ansible/ansible-4.8.0.ebuild
new file mode 100644
index 000000000000..ca5c06f44cf5
--- /dev/null
+++ b/app-admin/ansible/ansible-4.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-base-2.12.0"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}