summaryrefslogtreecommitdiff
path: root/app-admin/ansible/ansible-2.10.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible/ansible-2.10.4.ebuild')
-rw-r--r--app-admin/ansible/ansible-2.10.4.ebuild20
1 files changed, 1 insertions, 19 deletions
diff --git a/app-admin/ansible/ansible-2.10.4.ebuild b/app-admin/ansible/ansible-2.10.4.ebuild
index 86e5af4dd8f5..cfb7d42b3a3d 100644
--- a/app-admin/ansible/ansible-2.10.4.ebuild
+++ b/app-admin/ansible/ansible-2.10.4.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-IUSE="doc test"
+IUSE="test"
RESTRICT="test"
RDEPEND="
@@ -41,11 +41,6 @@ RDEPEND="
DEPEND="
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
app-admin/ansible-base
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
@@ -61,19 +56,6 @@ python_compile() {
distutils-r1_python_compile
}
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-}