summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4385 -> 4384 bytes
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-46.2-r1.ebuild62
3 files changed, 63 insertions, 0 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index 8fc9b662c5e5..4962a5eda2ea 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 69184649c86c..93c9c5fbab97 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,5 +1,6 @@
DIST orca-45.2.tar.xz 3997024 BLAKE2B dfdf113694127323a92450b04b20fcc5655be0236c0173167d5d15478703b676c3fd8c1de0e75783875c5d2d40541c764fb002314d66c7570475cd63f6bfa473 SHA512 57eee451cf0da52e1297beae6c6d527886721b23c3415a5e046f3431876fdf1603dbd81ca763ed614ace68e7db96d90b413c663f113d0033ec1f2797df7bf589
DIST orca-46.2.tar.xz 3431952 BLAKE2B 56b8c31318ecfaf6acda365192e0dd70feb835e449ebe1e0c0292a2230c44659ddc4e9cf1fa87aba1694e3ba2c8c695754901c4a797720979af3a8143f0b0b00 SHA512 e55d5dba18b70ac2b70809f9e0af82e1fad8c72d9f3a7e03c6e4c1da29e133f80b3dabf9ad007873587b4b01a4ff36947e4ea38d7afd60748f8f98219a6a24e0
EBUILD orca-45.2-r1.ebuild 1554 BLAKE2B c438058a0d3095768be3d7e2fd12a6e94d9d1cdf1d4ee455c4197daf0c46ca9d10bbd9f7e178d09b9c9bd4e8c401c10667ddd7e21f688b058634e7b757ee2ece SHA512 44f95a66073ed2da7098d2046500c97ff836bdf66128ad9863a2ade29c3c9e35be9eb6a567feba42395e10edd0b2bfe4a4166298b7a04d63460c071e9545eb92
+EBUILD orca-46.2-r1.ebuild 1500 BLAKE2B 5bfc030046b773501157a21001924280828c9c1bb3c103242955e2a0e431a573c30f34cad6121be4c83108a0c1675c5f5ed19098efcc13a86a24347349e26334 SHA512 df06cc609235f2e3856a4a34420353f002adf9def61ea1187434dd9a70e2286b188f6702f951ab297c4b6ce8b0bd2bdc4111042ae2c72a16db948eb54283b13e
EBUILD orca-46.2.ebuild 1485 BLAKE2B 8c4a58339927708adfee0180812cf2cec24f237b7850cdfc8050319811e3b955fe8e5e1c6e14528f9b98b9018bccf693de8feaff5f2f32ec8aa8a35eb85be7a0 SHA512 ec47165c180d5c31da610369680f5eb132c9f6bb641e4c65e23c8055ef628a7252b92a3245e8602d6dbac52374326ab06bc3b9b5a744a1f830c75da60618ee63
MISC metadata.xml 762 BLAKE2B fca9ee6ac93d2e860f6791af78380e9d8d29ac10b254299946911a29b5893028e561a18320bc026dd7e9421f3c572e1c3ac63264276a1b292996db93e1cba4a3 SHA512 6bbe0cff5af52cb48adccbb61620fd75a0811cad313867b63cb09b5a7c259230019a54ad607ee46c986188ff11ac2f6878ef20381ef34965dfe918c88ec945d0
diff --git a/app-accessibility/orca/orca-46.2-r1.ebuild b/app-accessibility/orca/orca-46.2-r1.ebuild
new file mode 100644
index 000000000000..d7404591ef65
--- /dev/null
+++ b/app-accessibility/orca/orca-46.2-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://orca.gnome.org/"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.50:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.46[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ local emesonargs=(
+ -Dspiel=false # spiel not yet in gentoo
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"
+ python_optimize
+}