summaryrefslogtreecommitdiff
path: root/app-accessibility/sphinx2/sphinx2-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/sphinx2/sphinx2-0.6.ebuild')
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-accessibility/sphinx2/sphinx2-0.6.ebuild b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
new file mode 100644
index 000000000000..d2fda0b62aef
--- /dev/null
+++ b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit autotools eutils
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="CMU Speech Recognition-engine"
+HOMEPAGE="http://fife.speech.cs.cmu.edu/sphinx/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old
+ dohtml doc/phoneset_s2.html doc/sphinx2.html
+}