summaryrefslogtreecommitdiff
path: root/app-accessibility/eflite/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/eflite/files')
-rw-r--r--app-accessibility/eflite/files/eflite-0.4.1-flite14.patch24
-rw-r--r--app-accessibility/eflite/files/eflite.rc28
-rw-r--r--app-accessibility/eflite/files/es.conf11
3 files changed, 63 insertions, 0 deletions
diff --git a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
new file mode 100644
index 000000000000..cb3096d88a43
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
@@ -0,0 +1,24 @@
+diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
+--- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
++++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
+@@ -34,7 +34,7 @@
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
+
+ fs.o: fs.c
+- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
++ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
+
+ tone.o: tone.c
+ $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<
+diff -Naur eflite-0.4.1/fs.c eflite-0.4.1.new/fs.c
+--- eflite-0.4.1/fs.c 2007-01-18 16:01:09.000000000 -0800
++++ eflite-0.4.1.new/fs.c 2013-09-08 09:31:57.417262688 -0700
+@@ -523,7 +523,7 @@
+ int playlen, skip;
+ if (type == SPEECH)
+ {
+- skip = (187 * wptr->sample_rate) / speed;
++ skip = 0;
+ playlen = wptr->num_samples - (skip * 2);
+ if (playlen > 0 && playlen < 500) playlen += (skip * 2) / 3;
+ }
diff --git a/app-accessibility/eflite/files/eflite.rc b/app-accessibility/eflite/files/eflite.rc
new file mode 100644
index 000000000000..2a65b04d0a8a
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite.rc
@@ -0,0 +1,28 @@
+#!/sbin/openrc-run
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ use alsasound
+ use modules
+ use hotplug
+}
+
+start() {
+ ebegin "Starting eflite"
+ start-stop-daemon --start --exec /usr/bin/eflite --background \
+ --quiet --pidfile /var/run/eflite.pid --make-pidfile -- -D || eend 1
+
+ SOCKET=`egrep '^sockname=' /etc/eflite/es.conf | sed 's/^sockname=//'`
+ [ ! -S ${SOCKET} ] && SOCKET=/tmp/es.socket
+
+ chown root:speech ${SOCKET}
+ chmod 660 ${SOCKET}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eflite"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eflite.pid
+ eend $?
+}
diff --git a/app-accessibility/eflite/files/es.conf b/app-accessibility/eflite/files/es.conf
new file mode 100644
index 000000000000..17443d3e42ba
--- /dev/null
+++ b/app-accessibility/eflite/files/es.conf
@@ -0,0 +1,11 @@
+# What socket do we listen on
+sockname=/tmp/es.socket
+
+# What volume do we set?
+tone_volume=8192
+
+# Do we use the PC Speaker? (0/1)
+speaker_tones=0
+
+# Do we use the sound card (via flite)? (0/1)
+soundcard_tones=1