summaryrefslogtreecommitdiff
path: root/acct-user/unifi
diff options
context:
space:
mode:
Diffstat (limited to 'acct-user/unifi')
-rw-r--r--acct-user/unifi/Manifest2
-rw-r--r--acct-user/unifi/metadata.xml22
-rw-r--r--acct-user/unifi/unifi-0.ebuild15
3 files changed, 39 insertions, 0 deletions
diff --git a/acct-user/unifi/Manifest b/acct-user/unifi/Manifest
new file mode 100644
index 000000000000..c38bc843b481
--- /dev/null
+++ b/acct-user/unifi/Manifest
@@ -0,0 +1,2 @@
+EBUILD unifi-0.ebuild 309 BLAKE2B 5e0b6c55d7feaf94ff3f281a43763e41a3ede8d620cab68cdf7fa831a657a4da6df350c85fa4b101e8522753562d47a941c95ddee8bcdb8504866da912b223fb SHA512 45a7b3053738366abff90b2fb6d2242785e13e94ae1afd2fa7c6712138a69ace79a68c486c8eb9da63b5f99ad3d07e9949a4b66c13e02bb922f8243034bf1cbc
+MISC metadata.xml 803 BLAKE2B 5d50d4d0c8353661b471d243682812f77cc9a969d3117c6cf1fff60ecef4e83767b8e235cb0e010383bf1f754a7f1a1261a73427b3bfc1446f7ef08ba837ab36 SHA512 2588b43cf7049379def1b487815c317377e8e04293e54dd6035c50ce612f0ce3ac2039c3802eb7b9b6be172c49aef68f28a547fec5f565e42acaf0d2fdac8abe
diff --git a/acct-user/unifi/metadata.xml b/acct-user/unifi/metadata.xml
new file mode 100644
index 000000000000..57ba2066974e
--- /dev/null
+++ b/acct-user/unifi/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ UniFi is a management controller software for Ubiquiti UniFi APs.
+ It's purpose is to configure and monitor all those APs.
+ Also all kind of statistics are collected, which can be accessed through UniFi.
+ There is also an internal RADIUS server, which can be used for WPA2-Enterprise.
+ </longdescription>
+</pkgmetadata>
diff --git a/acct-user/unifi/unifi-0.ebuild b/acct-user/unifi/unifi-0.ebuild
new file mode 100644
index 000000000000..0f750e70188e
--- /dev/null
+++ b/acct-user/unifi/unifi-0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="A user for the UniFi Controller"
+
+ACCT_USER_GROUPS=( "unifi" )
+ACCT_USER_HOME="/var/lib/unifi"
+ACCT_USER_HOME_OWNER="unifi:unifi"
+ACCT_USER_ID="113"
+
+acct-user_add_deps