summaryrefslogtreecommitdiff
path: root/xfce-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-15 12:22:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-15 12:22:30 +0100
commit3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (patch)
tree497e5c46d6f6695b96866bc46abe1a2470a880b5 /xfce-extra
parent792e307954fd3b5b12c968741d76ea7cfe5206e4 (diff)
gentoo auto-resync : 15:08:2024 - 12:22:30
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/Manifest.gzbin7713 -> 7721 bytes
-rw-r--r--xfce-extra/xfce4-hdaps/Manifest1
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild45
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest2
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.6.ebuild74
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest4
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild53
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild3
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild39
-rw-r--r--xfce-extra/xfce4-verve-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.3.ebuild34
12 files changed, 200 insertions, 58 deletions
diff --git a/xfce-extra/Manifest.gz b/xfce-extra/Manifest.gz
index db990d7c23ff..b440c8cb1d2b 100644
--- a/xfce-extra/Manifest.gz
+++ b/xfce-extra/Manifest.gz
Binary files differ
diff --git a/xfce-extra/xfce4-hdaps/Manifest b/xfce-extra/xfce4-hdaps/Manifest
index 205ee7a3f4b7..4bb907656528 100644
--- a/xfce-extra/xfce4-hdaps/Manifest
+++ b/xfce-extra/xfce4-hdaps/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-hdaps-1.0.3.tar.xz 350936 BLAKE2B 37d80bafa831be68b55f66c029ec120b67ea1a21760291f05cf11587161b295698a5994df3abb9eaa2c3ff94af7b0f43a3cfd04cef31993d741918b4eb7e8f49 SHA512 9263a6d63b4e4cd9729a87ae5150d10a6ef3a2bde48b5a82334e948d884869ed2492953eaef4df08b6a2155454ef81af6b83e70f1436cfaca4f2fd8e39b5ac34
+EBUILD xfce4-hdaps-1.0.3-r1.ebuild 822 BLAKE2B 0c335fe0024352bd005c68965bba0eaaf11ecba59b8607248f76b95becd2e56ccdbafd269c11edc7cb6613420b311fe94392a6cb34047ea2410fc7d72e4d87d6 SHA512 f0f3a6e7ed776ce837291cde54c356954e604ad3948607d7f6b46aecbdcc11f2e2cefc335276a77ce38364411a52809c631c51655683213af7078ac1c08b7071
EBUILD xfce4-hdaps-1.0.3.ebuild 814 BLAKE2B 6e3e8a6122fe354b9f94a1fbd6ba4a39f00084797cd1e2ecc34c4e8d509bc3a2f2868c2742f406995cffaecdb7e4345496d3b52b90a52325ca0b8b790a192734 SHA512 6293955fd7ef507cda05c55388dca10dc150595ab19d312d5f20f1267fda5d1f54442652ae0db506e36d6f172b7a55cb045b862af23f292097d329995f0ddd30
MISC metadata.xml 361 BLAKE2B 5cd2add88280a250320d9cddf426824cfe890a02b933c25007419c293c0d8550419220d078310c971f80c0bbbd6799a24abbcead8f04e970980c1a8150290bf5 SHA512 c06790d6a518af011bb7cc31ddc75754de480e5a6a0726ba5dba4f728f210dbc85342a6228a398fa1452424b61cfb1b1ced19dd5fc3c8a4c3664a7411eb77267
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..64f82e508edd
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Show the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="https://michael.orlitzky.com/code/xfce4-hdaps.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+ app-laptop/hdapsd
+ app-laptop/tp_smapi
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index 57f8b9974fc7..1cd8f5baec78 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1,5 +1,7 @@
DIST xfce4-notifyd-0.9.4.tar.bz2 732160 BLAKE2B d0c47875acf638f44ae8188c7a39f1785a9e3c489f4fad209e9c591780a91b0439037a0c62351619f71d2765dacf11a786d5678c03ec846f4aa0a0bc0b823166 SHA512 d3339ec3555f27e624e643b52ce4de2a0834d38f675b286976abcb4e143cbbb32665b1f36fbff23791c152e1f0616b752a7f049045fc32829c27c0a87d82df94
DIST xfce4-notifyd-0.9.5.tar.bz2 740324 BLAKE2B 900b9487a888e7d1b7112d1f088605d4773d9baa7d17a369ef0cc4e6e00ecfb9ac72ba760044031090048e1d1aec2a8ef5c11c5246ff84b9a14ccdfbda014138 SHA512 9e8d81ccb16c3eb72ebea24ac03a0594d3f9ddd20c7edcaf9f68e288b2d5115294d5c9e2911c15e6d8032d36cdcfc423ee51b56a20268a035a3fb7ca65c41bdc
+DIST xfce4-notifyd-0.9.6.tar.bz2 742198 BLAKE2B 8bcd2df7e7b8727ba05f94577e3fe9a575c0801bccb841e4077f5150578f2b7faf25444193da45ddfef870d9cf470793b0c152b939f4391421fa226a39eca9f3 SHA512 deef625fdb7828ac25a3eeb2c5e5813f285310354b33a81e1c7943024d9dee9e9b5765f94f7e7ccedd1998dab77eb2c62a2803864d56aed6f831f08b910f0071
EBUILD xfce4-notifyd-0.9.4.ebuild 1329 BLAKE2B b7dd478aeca99d4960f3590630ee3e856919dda942a32fb6e302940a9c74d39a2e4c08be4f8a2a7fa3d3d1d47d62afb7cb6daff7dad5bce11bd1668e21f5c7c2 SHA512 db6498916cf03d325b6deaab8f4a5e6b0805ee4075a79b96ad23c19c27f9528cf6ea2037f18d578d779df0ebba3f9e1442d335d2e4cfeaae2b39520ddba092d1
EBUILD xfce4-notifyd-0.9.5.ebuild 1332 BLAKE2B 54b783521a985b0b308846c93d994006189c428ba1e7594abdf6e315c9df28eb007d16c99743938886b091f3a407b9f02129402cb408115c71f05f40ed160973 SHA512 1706523bb00810499604b7ba5536e1377bb14d8101027b877c62b3922c4ef6ee29cf345950bb5f6c4c963709752d55992ade8f133a025257c8064199bec933de
+EBUILD xfce4-notifyd-0.9.6.ebuild 1332 BLAKE2B 54b783521a985b0b308846c93d994006189c428ba1e7594abdf6e315c9df28eb007d16c99743938886b091f3a407b9f02129402cb408115c71f05f40ed160973 SHA512 1706523bb00810499604b7ba5536e1377bb14d8101027b877c62b3922c4ef6ee29cf345950bb5f6c4c963709752d55992ade8f133a025257c8064199bec933de
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.6.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.6.ebuild
new file mode 100644
index 000000000000..f1b06c391860
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.9.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/notifyd/start
+ https://gitlab.xfce.org/apps/xfce4-notifyd/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="sound wayland X"
+
+DEPEND="
+ >=dev-db/sqlite-3.34:3
+ >=dev-libs/glib-2.68.0:2
+ >=sys-apps/dbus-1.0
+ >=x11-libs/gtk+-3.22:3[wayland?,X?]
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ >=xfce-base/xfconf-4.10:=
+ sound? (
+ >=media-libs/libcanberra-0.30[gtk3]
+ )
+ wayland? (
+ >=gui-libs/gtk-layer-shell-0.7.0
+ )
+ X? (
+ >=x11-libs/libX11-1.6.7
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable wayland)
+ $(use_enable X x11)
+
+ # just service files
+ --enable-systemd
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index 06da29beb0df..26b62a4b437f 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,5 +1,3 @@
-DIST xfce4-panel-profiles-1.0.13.tar.bz2 86671 BLAKE2B 0bf2d39aa2d7d21a99a9a7245e5de9e717b628f0eded2736db70cc87c4f6e1e1d10aecdc6586c43c6355747e68a2ceb1920d5309bf38ede07c1167c590dc116f SHA512 648324e5dd95ab0a513829d7d816e2113ae677d9ad6ac9b01d73c6b4105b54d5e773150d5440ad35a37b4dc75478f40a24e0223decf940f3cf658241547ce75a
DIST xfce4-panel-profiles-1.0.14.tar.bz2 101521 BLAKE2B 197ebba356e8d7661779531147b08454762a9b61beebd2323bc9e88b26381952c2caa58c6fb110680a5038fc19422852722d72dfde09addb68ec9424ecf16a23 SHA512 e316e9d4f0d27b16ce83a50adfe1a3fe2102b7f5c3ed9e9ceebf5968e265064b4d4ade1e0dbd84180758a9c1fa72d8df1fb4d06a631d07956ea8add0f66da984
-EBUILD xfce4-panel-profiles-1.0.13.ebuild 1077 BLAKE2B edcce49026d3566653cc0e2d3ee31ec8f42561c1a262a349468b1d3f95a4cd7037dafccd50f7554a0d3cfc6c98ba067a35335590a90d7c0a332b504aad091c85 SHA512 46041023ddc9407eabeec8eb6b2f8a278da3fffe610fb8f591f6a5ab8b2268ffc2b388d0188b36dd23387edad7875d619fb2938fcc9a5e393fba30f54c3f7b2e
-EBUILD xfce4-panel-profiles-1.0.14.ebuild 1078 BLAKE2B 8249b7f3fa44243104fe9028b52bd1a0a55c0debc5c725226a0221ca2392e428c4838cd648a462b2950a8d16e68732957305f5267d6898cf4dbbd8290f3753fd SHA512 fe266da58f82dd55e054a99749617fefd8fe61c931871ebb759656e2a99719da557795cfa5aff0874fbd8241d8212d35e8efe7d1b7747f6660069ffa3dcf191a
+EBUILD xfce4-panel-profiles-1.0.14.ebuild 1070 BLAKE2B 38161157b1d14ffa6e2a011f360e6dcfc0c11a9ba75c68bd8d1fe48db7caaa1941ce3c1200cdca80e4907a4b0f19b27d12e621493436d5be6d27c3ec37954e3b SHA512 109fce85e27fc4541ad1d9f4b26a57bb2f1a18ab61e273adfbf25c76a1852ad58dbce49a2cf29268d788ac0a4f4f011b421f1b410be622c13b3bdecf480520dc
MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
deleted file mode 100644
index 18b93a196b47..000000000000
--- a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit python-single-r1 xdg-utils
-
-DESCRIPTION="Simple application to manage Xfce panel layouts"
-HOMEPAGE="
- https://docs.xfce.org/apps/xfce4-panel-profiles/start
- https://gitlab.xfce.org/apps/xfce4-panel-profiles/
-"
-SRC_URI="
- https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2
-"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-BDEPEND="
- ${PYTHON_DEPS}
-"
-RDEPEND="
- ${BDEPEND}
- dev-libs/gobject-introspection
- $(python_gen_cond_dep '
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- ')
- x11-libs/gtk+:3[introspection]
- xfce-base/libxfce4ui[introspection]
- xfce-base/xfce4-panel
-"
-
-src_configure() {
- # home-made configure script, yay!
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --python="${EPYTHON}" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
index f7ba0bc11386..275e605f5c73 100644
--- a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -19,7 +19,6 @@ SRC_URI="
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
-IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
BDEPEND="
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/Manifest b/xfce-extra/xfce4-smartbookmark-plugin/Manifest
index 3a814e582e68..2e64a4a95209 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/Manifest
+++ b/xfce-extra/xfce4-smartbookmark-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-smartbookmark-plugin-0.5.2.tar.bz2 331765 BLAKE2B 00985170c8313b422747ae287d10c4fad6953ae1591d8f666d4beb4cf5323e3e020809f34da5228322ed396f33d43ce4608964f085724a3fcba8fc0cd2114b16 SHA512 56c5b4d366826de0b25f5665875f15d950a04ead7a3b5a7e546f27880363d47f3a1bba2c02e1f8ffd08b28cc4d4466d648740efda86ee8f378e0f8e721582b5f
+EBUILD xfce4-smartbookmark-plugin-0.5.2-r1.ebuild 925 BLAKE2B a5ca0761c1310a4e28b0f2cc0f7168167a8a572812b082031ae38d72065fd0d47bf83ff81a106c04ebd6f25d2c013cd9feb59ca715ebb7c8178d9de0cdd74c8a SHA512 ac07e3b4ff33f610827ede53e0b0f8b3377e3d460e96fc21f72137bdeb51ada84e003387fa4185bd3c43e5c263d0ac10a6469fb79b83827cbb0a353a682f3c86
EBUILD xfce4-smartbookmark-plugin-0.5.2.ebuild 851 BLAKE2B c43a6250e9dcc7f482b561580d55ffbaedb0b404d0c4eca78fd29f9794e771d0b2664cf03b273b6f09976bef43e98c229db397e616e0ae84bdb4d49f153de4e0 SHA512 900fb73f5c6d2aa9a244b50c4893abce15ed59b390cfa21b460c00c4a8fb89628c72ffe55141228d3d5cc1fa509262c95569feeaf41ffeb02e28e1721996c41c
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..5c9a9afe7965
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin/
+ https://gitlab.xfce.org/panel-plugins/xfce4-smartbookmark-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # substitute default bugtracker
+ sed -i -e '/bugs/s:bugs\.debian:bugs.gentoo:' src/smartbookmark.c || die
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/xfce-extra/xfce4-verve-plugin/Manifest b/xfce-extra/xfce4-verve-plugin/Manifest
index 57faea83ec82..ac0a8303f105 100644
--- a/xfce-extra/xfce4-verve-plugin/Manifest
+++ b/xfce-extra/xfce4-verve-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-verve-plugin-2.0.1.tar.bz2 384412 BLAKE2B 3a0370b1027fef00d748de43bf420271e8d093a203a1c77dfbb8ecd093e139d35ce6f7d585558635b2f5566dc49d8c226c9d6ebe88e7a785ffeabe1a9c8f63eb SHA512 c8397bd833e2a2cf25d86bd9234bdbafed00ce0783273532a57e87a5182d26b3e84b402ed8c9fd9204d5d46fbca257fcf6601f279d9929d806a4c36338379876
+DIST xfce4-verve-plugin-2.0.3.tar.bz2 383536 BLAKE2B 42202d50d3c8533658b096d5a8b6347d71bf82dd3b30d61d3adaaf313d53047d0bd78a6195f18205b095f088ba08a7411a1a9493637a0ffcc5acafdbbd9dbcc9 SHA512 acfa0c9ee19904a0cbb5118bbb3324499a6fcfbf881478bfb745e0675be89aacb4ccd23137ba78fab0fe77e2e4b67a0c815cb3f37ee8132ebc09aecf9aaf1d1e
EBUILD xfce4-verve-plugin-2.0.1.ebuild 826 BLAKE2B 993900dbc2b34571fd178f141aceec7af0790cf129058c358dfc9a28afebff50a1e749bf3ce325ddccb95efa75cd16a66f27094b180ea9a334186076918ccc51 SHA512 17dcac534ae00603c6cc86c1e00858efd1f054f1ab904c0feb20c6a16562b6e131f2e06ccaa42a974cfa7e565eae411b80f52f3701c2ceebd0ec695dce0a784f
+EBUILD xfce4-verve-plugin-2.0.3.ebuild 784 BLAKE2B 4733a1de67c66c2972535e293097418eb3ea85d4811da58a68574d4b443e7e161c83002c56e287750df6e5c0139acd0a11791d389fcb71f548cd4e311c3f5823 SHA512 3aed882d2b0b4bebc1ffa39781f23443648145e5458c6f9e2693a7c36129620256d0d89e3b60c92218e78d197e1414cae59be56bc59f58cd46f6493e891ba610
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.3.ebuild b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.3.ebuild
new file mode 100644
index 000000000000..4245ad858b09
--- /dev/null
+++ b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A comfortable command line plugin for the Xfce panel"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin/
+ https://gitlab.xfce.org/panel-plugins/xfce4-verve-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libpcre-5:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}