summaryrefslogtreecommitdiff
path: root/xfce-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /xfce-extra
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/Manifest.gzbin8213 -> 8218 bytes
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild37
3 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/Manifest.gz b/xfce-extra/Manifest.gz
index 9f299ad76d0c..891a52f241d0 100644
--- a/xfce-extra/Manifest.gz
+++ b/xfce-extra/Manifest.gz
Binary files differ
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 0dd75e3731f6..3ec44db6c4f6 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-cpugraph-plugin-1.2.3.tar.bz2 427880 BLAKE2B 1e2223eab1c8db275eb2aa43197c9aac8a79faee96778a5b684c0dc74e1b55046d0c1bbe3c00d316118be33ef3ee3777cafd258ef3919d36bbbb073e51fc9455 SHA512 79d7c5b328e778156c6a35b1f4947732f42aaffb23f05fdc5e1e7668d03149f1a72ca4bf9b835904a93db6b23660cb10118b4d046b1bd2dded38ef382719052e
+DIST xfce4-cpugraph-plugin-1.2.4.tar.bz2 445048 BLAKE2B 03c8c6f3aa0ffcfda930e79b851e6c6a425cab18986c7968fbdcecff3b251dc3134aab0c632d13439208445d0786e6e29a9835ccdff189bf82ae95b9b6576d6d SHA512 0a31b60d263f53db9e19165580c6f03a826e514f41b24555b007ae12b0d038d5f1447e637aa21e77cafe9970177dbeab373385e223f77768d46ede4f1adb0ad2
EBUILD xfce4-cpugraph-plugin-1.2.3.ebuild 815 BLAKE2B c070d7478c0da519addbc77b994ef70b02bf2305f77dbc7f54ddda572ac525a921f5cba4dda9b14082f8f56815f556c1858799f70ed12672ea95339006b4a354 SHA512 9c995793b7412222b659740866971b37841a08e35cf8619339aaa3b7a6aa6061e2477750bde0ca00d5d45a29a52d929c1560851af7c72e4fa58bc070f893c8c6
+EBUILD xfce4-cpugraph-plugin-1.2.4.ebuild 851 BLAKE2B c2b80ad2e422542d1196db425d8be21b7c3b0352c0813722f1f8671259745278f6c91c97143875f85c005294d2987ed6c421a93464cf62f900a75e39532ba1a9 SHA512 26ea9ce50fe8d95116ed6704c520684ab12b1abcc89075e669a00880846effb1021aa181b8503bd7798bb0e427d25567db2aa29d79704bfd7f1d7acd2bee08fe
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild
new file mode 100644
index 000000000000..6e63cc625b45
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}