summaryrefslogtreecommitdiff
path: root/xfce-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /xfce-extra
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/Manifest.gzbin8047 -> 8042 bytes
-rw-r--r--xfce-extra/xfce4-indicator-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.1.ebuild51
3 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/Manifest.gz b/xfce-extra/Manifest.gz
index b073a7b25a76..7609b26e4090 100644
--- a/xfce-extra/Manifest.gz
+++ b/xfce-extra/Manifest.gz
Binary files differ
diff --git a/xfce-extra/xfce4-indicator-plugin/Manifest b/xfce-extra/xfce4-indicator-plugin/Manifest
index 4f492f5b23b4..7a49ea3ba0d8 100644
--- a/xfce-extra/xfce4-indicator-plugin/Manifest
+++ b/xfce-extra/xfce4-indicator-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-indicator-plugin-2.4.0.tar.bz2 389228 BLAKE2B 6f627663d0a432ee74e871b55656c119f99c315d2f5095fd24a9eefc9338d280d5c371153377d575bc926707f30dc0602c7033bf09acdba1e247356b341393d5 SHA512 5b6e82d85357cec689f23a6cf69d379db9425956a531d8295a23adf52b1e00e3cd8acd822b13ab05d80321ff739c96aadc6e7526ec275421c341446e58a5fbab
+DIST xfce4-indicator-plugin-2.4.1.tar.bz2 406823 BLAKE2B e24107888c8af7206111b4d6b8058e871b97aa687116684a3251cf731f9925bed1cfec3c1fd8a66794c6fc31bd631a4cdc7924972956c12eac3b12f4d7f18831 SHA512 a5b9b25b405888a69708eb43656ac58a728d4a5a9736b5513d23b17409b5d8a0230cf89e6243afde5b1a3edad43b38915d007551347c85a7d17364760c2dabba
EBUILD xfce4-indicator-plugin-2.4.0.ebuild 1115 BLAKE2B 1e1de90a318f767fff8fde2adf1b766df1af435ce9a522b460850ce2e44c61c08e2417ea2933c16ca64c52c2a35cbfa2fa7c873243a12a8a0953921441d20a32 SHA512 6b0b7be745e2fab32cbf20009b0e94aa11bd07904ec07804a7ad683da09207f8c76760ab3e1332373f7a26d66d00eaf91cf0b85186d903fc6fc38d816b49cd95
+EBUILD xfce4-indicator-plugin-2.4.1.ebuild 1115 BLAKE2B 810a1b9c627675ca87c47d9c4348eef8c95adafb5d6e5213312b1d2d066805a087e46d891091d41494cd4f5951baa52ad8bec21614f9df0f0d18f127182ffe80 SHA512 a832e5db845411109ada4c102071265da46dc4a3b0d164d17a183fa90b6a994d187f21f4016ce6f86a5df76f443b65d70c8def965ec66aef89b27fde14b27fc2
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.1.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.1.ebuild
new file mode 100644
index 000000000000..dcee8758700d
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3=
+ >=x11-libs/gtk+-3.18:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/xfce4-panel-4.11:=
+ >=xfce-base/xfconf-4.13:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ # libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ --disable-ido
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}