summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-wmdock-plugin/xfce4-wmdock-plugin-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/xfce4-wmdock-plugin/xfce4-wmdock-plugin-0.6.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/xfce4-wmdock-plugin/xfce4-wmdock-plugin-0.6.0.ebuild')
-rw-r--r--xfce-extra/xfce4-wmdock-plugin/xfce4-wmdock-plugin-0.6.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-wmdock-plugin/xfce4-wmdock-plugin-0.6.0.ebuild b/xfce-extra/xfce4-wmdock-plugin/xfce4-wmdock-plugin-0.6.0.ebuild
new file mode 100644
index 000000000000..99dd20a41051
--- /dev/null
+++ b/xfce-extra/xfce4-wmdock-plugin/xfce4-wmdock-plugin-0.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="a compatibility layer for running WindowMaker dockapps on Xfce4"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-wmdock-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND="x11-libs/gtk+:2
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/libxfcegui4-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=x11-libs/libwnck-2.8.1:1
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-LINGUAS.patch )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog README TODO )
+}
+
+src_prepare() {
+ echo panel-plugin/wmdock.desktop.in.in >> po/POTFILES.skip
+ xfconf_src_prepare
+}