summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-weather-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
commitd3bd579653c6e5f8e1c0a36517372a262ade6c8d (patch)
tree7078b1e6375421ced0dbdd93a81dee1c6a3e04a3 /xfce-extra/xfce4-weather-plugin
parentebd51986f51b430f84c569c6c0f2fe051158d444 (diff)
gentoo auto-resync : 22:04:2023 - 00:03:23
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin')
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index bf7b0c32ce8b..e7b1f5c7903d 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-weather-plugin-0.11.0.tar.bz2 3019896 BLAKE2B 3ab8c2d16efb47f921ad5b6511428545553959fec52973f0735706d42b8b260c10f6a1be6db56e9b6f02bca75eaf41d8543be6ac3afd7bb1e44a75d9b6615ff3 SHA512 f4534d47f825358752ec6252fd0fc49a44ac682e4cdce960d744cd343f5f670473fa4175c59849282352dc75ca9b22b83d7ace68cedfc7dc89bcb21be24ccf86
+DIST xfce4-weather-plugin-0.11.1.tar.bz2 3100215 BLAKE2B 454fd3d4f1d40123b4ffd6f648b43079be444fccb876e123604deeee51741819ab3b65d81e56af9f25dce720f34d706f6c87211619a8e55b7f9f41bb5fc530e1 SHA512 625b2aab1ded60eb39171969cd67224569cf7477c0a6e47aa5600a4a09b4a2cecd4b830f4c01669e6f2289edd4e7d882b15d56526a1211b8b5b86141b585778f
EBUILD xfce4-weather-plugin-0.11.0-r1.ebuild 1107 BLAKE2B 085b5c794e4a18b3a945379d6da5a6a66955a8d8c61c3bfb6cf1a8cf5f554326cf0f7ffe1372288e461c62d61d5270eafe2a842c91827c94912d511dee285074 SHA512 877b08fbc6dd1f1ae5f1f28c9ee1ec4751d9445631480805384b9becb10d0771294f4a4fa54ed3aeb597bf4be64001b2e5091e87cd695727ce7d3b871a25c511
+EBUILD xfce4-weather-plugin-0.11.1.ebuild 1187 BLAKE2B 924bcfab8d9edb08c205e11d479823f48f075472f2924725eedc17d9fb76c941acbc39f1817b1bddf286271d0f7f0e3c1c899793d3dcafe732e2a9267effadc6 SHA512 12102cd365ce44c5bba4a1c87d181c04083237a94f4d91c1d6260d5e1cb5ddb2a3b57ac74cb056acc4a3245d9ebe168a3833d51077f765c3bbeea6dda2e279f3
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild
new file mode 100644
index 000000000000..c16e116d9447
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.11.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-weather-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-weather-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="upower"
+
+DEPEND="
+ >=dev-libs/glib-2.50
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.42:2.4[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.12:=
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}