summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-weather-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /xfce-extra/xfce4-weather-plugin
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin')
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index beb36d634ddb..937f23dfb2b4 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-weather-plugin-0.8.10.tar.bz2 2991350 BLAKE2B c3c71952a196d49068bac9c1de0695d2845db6931cfe220caf5ebb88919eb40fa0fc9c9a6dc640adbd82fa284449daf6ac537aaf5d258108083b2e63d8288610 SHA512 e40f794e824cc48038ece0c1336eed21b2e28091b86a4b76099c092c2e45abc5041d010d286f64fc483e8ad7c496127152df86330187afbd0872506d89f37c35
+DIST xfce4-weather-plugin-0.9.0.tar.bz2 2953904 BLAKE2B 6d8cf9b4d58b538b89ff72149e065d744f38333de9636baf0209bd49db130a3a0dd035a4c5c216bbd41302511a2784fff1d0ea90722d1d0409a44de0cfcb17aa SHA512 2a6fbeceb99d809cc4a928d0d53f92c7c638adbdc78d39dc2857b3506fb4287291702f078b547752176e0d2660a6365b62a7d8459ab88bea744dee28268e326a
EBUILD xfce4-weather-plugin-0.8.10.ebuild 1089 BLAKE2B 1e63f72c0b9c6ff7ae193f77bb0829d7c08fb894985091e481e2c9bde190c222eb24b24606ad2407f299b8c33b7e4a665dfbdab6fdee133569c3d38b3853d5f4 SHA512 525c021213d65127f653ec5104714cee2b188ab249cc2ff4363a18277e32cb72d6c8418e147b8c045f843829dfc5db930257a6a258834dcaa66ff46eba31e406
+EBUILD xfce4-weather-plugin-0.9.0.ebuild 1044 BLAKE2B 658327918d73a085fe58811fd089ff54260d441b011b5220a6fc1cd34f7809dea05fd7bf78cc23d0bbc7422b775c53ec9169fb83c242c3bc84fab6ebad37c759 SHA512 e7bbd52131ea849b95e4f50ef7476e33efb392e75c33f14561e425cabfb2dd6e92e71839657ae3d3192fb0651b8001dbbe39d1b08448156d04cdc0bc8fb0c094
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild
new file mode 100644
index 000000000000..07104d920809
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.42
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.42:=[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}