summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-timer-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 23:56:27 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 23:56:27 +0100
commit93d0bbd7df69c2081c2b2347ea6c88b8e967d537 (patch)
tree5a3d99a67d4243c300c70a88d52d651c1de4688d /xfce-extra/xfce4-timer-plugin
parentb481b54b8432c46df354eedc3532b0420a38fd5a (diff)
gentoo auto-resync : 18:04:2023 - 23:56:26
Diffstat (limited to 'xfce-extra/xfce4-timer-plugin')
-rw-r--r--xfce-extra/xfce4-timer-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-timer-plugin/Manifest b/xfce-extra/xfce4-timer-plugin/Manifest
index 30106d46eb24..1aafd7039ae1 100644
--- a/xfce-extra/xfce4-timer-plugin/Manifest
+++ b/xfce-extra/xfce4-timer-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-timer-plugin-1.7.1.tar.bz2 405053 BLAKE2B 1efb88f9b4e7d1ace747950f97c1d0beaf7e9194bab639c4f8eb650378cd216f621fe30e7fbb874e73acffd1c3b30048754f07ed8fb64e96260fb831f3ff62be SHA512 4887dc2c524a8b749a20449dd491dc8f12f8babb26c64cecf33ae56b45d2446128cb65c25f11d534278ad39a2adf7ab718714e1bfa613fd39713e44642030c16
+DIST xfce4-timer-plugin-1.7.2.tar.bz2 414526 BLAKE2B 419544e8088b518cd597c6394dafe798cffcfaeefcfe4fbd11f75e9709ad7990e44b5cddca438bb4960502fab8bc6127e3e37d2899e892a1f4ff980e97a48f5a SHA512 11a3b146c56f1526530b7f810c76ba95ef4dc7c113fa0ad2839494a5bc66c09f4a3ff966bc5d76055482a284c6c082b08a4b6af4684e5ccdec67946b0cdd820d
EBUILD xfce4-timer-plugin-1.7.1.ebuild 847 BLAKE2B fac1a5cd86e556a8b92e715f45a407d42676157da7be2ac4d3cf006aec1ca8abea2f346fa2f04276b9534680afd959eba13f0e27d328fc476130d82a6c028bfc SHA512 8783afeb88c5340e26774c2fea3b70c6cb96a4257d2a61514ebf0c7d49b25f6f7413fa1e04007ef4c4f8db433ff780dddc6d9305347529ab1dda05a012c83bd4
+EBUILD xfce4-timer-plugin-1.7.2.ebuild 931 BLAKE2B cf148170722bdb1ceab092c5054d217823edf36ea0ee0eac47ace165131ef72c11d8731630be99080ef39130f73248310f3835a8b19fbe0b6e792a4b64b3b7f9 SHA512 3181b0a809b55442ec0bedbc5f8facbae1c400db55f714a1170505745a4e46a8a094640913837282db55de6ee499cac67b44e951aec09235f81029bd186d091d
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild
new file mode 100644
index 000000000000..daab347695f0
--- /dev/null
+++ b/xfce-extra/xfce4-timer-plugin/xfce4-timer-plugin-1.7.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A simple timer plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-timer-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-timer-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.26.0
+ >=x11-libs/gtk+-3.20.0:3
+ >=xfce-base/libxfce4ui-4.12.0:=
+ >=xfce-base/libxfce4util-4.12.0:=
+ >=xfce-base/xfce4-panel-4.10.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}