summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-time-out-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-22 00:03:23 +0100
commitd3bd579653c6e5f8e1c0a36517372a262ade6c8d (patch)
tree7078b1e6375421ced0dbdd93a81dee1c6a3e04a3 /xfce-extra/xfce4-time-out-plugin
parentebd51986f51b430f84c569c6c0f2fe051158d444 (diff)
gentoo auto-resync : 22:04:2023 - 00:03:23
Diffstat (limited to 'xfce-extra/xfce4-time-out-plugin')
-rw-r--r--xfce-extra/xfce4-time-out-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-time-out-plugin/Manifest b/xfce-extra/xfce4-time-out-plugin/Manifest
index c0ea54352467..74e03b033105 100644
--- a/xfce-extra/xfce4-time-out-plugin/Manifest
+++ b/xfce-extra/xfce4-time-out-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-time-out-plugin-1.1.2.tar.bz2 409221 BLAKE2B 75a6f646badb936a803d8e6a8c9c25c85fa76f96fa82bae742724d3b52a68c49f81f58600a91de6ceb0f85220aa2d6b3a3ae2525a38e4f8a5fd78d4fbc6f0dfc SHA512 08e50db9daafd9a2ba60e9d5767cddba83df34d8a261df71b7bb9ae632576f4dfd6252c2a83ec8f9a037284b0adc65751ba36d54ea9d14b85906fdc85d5b86ff
+DIST xfce4-time-out-plugin-1.1.3.tar.bz2 407981 BLAKE2B 4dd2e7ecd4bad79d0e16d94ee5f5f616477a5f0cd0a6eb29612bd2bc35e92d57aa05781c28b1257f50b0f3eb53bef20a3a6d6658b2657a356aa452a097e6b7f1 SHA512 1abb5b8efa985b08968c49bb01a6efd49bc43f16f4b80f892086643444979dab3b7819d7f7e51e4c898c92387c213684b0c28765624c1f04303c0674c5b91930
EBUILD xfce4-time-out-plugin-1.1.2.ebuild 796 BLAKE2B 1edc400a7842e498b5ce0a9deb22bc51780180949246c00c804eecfb9bf8660c2c94fd079e9bb3dd24519d21dd307c67684905b91c65cc0caca282ee0e14ef19 SHA512 7db0c40d650dd2d358e644aaacfd5181e635bc7f4ae221be45bfab2c19755f73144833bcbee5b7ab570786f837cca5ac0423a3abad57b91acead8e06c4faa3ae
+EBUILD xfce4-time-out-plugin-1.1.3.ebuild 922 BLAKE2B 853cc90c0b33fc5d9d6042863b3ee921dc7f242a76f5cbccc1a3eef9ce641508111e8a34f3144e5ce31f250b85d0109d7288e270c7736337dd6b0716445827d3 SHA512 fb6b502b01191b0b0e7b2178ccbf1f9d7b5b84f262b563f6a3350c656f4d66397405b63367b458f9f96f5c93f122aef863d183f3544ccbf7ee65ba62642fccb4
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild
new file mode 100644
index 000000000000..7403e17ef3ad
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in to take periodical breaks from the computer"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-time-out-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-time-out-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}