summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-smartbookmark-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /xfce-extra/xfce4-smartbookmark-plugin
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.1.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/Manifest b/xfce-extra/xfce4-smartbookmark-plugin/Manifest
index 05cc673e893d..1924206e9eb1 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/Manifest
+++ b/xfce-extra/xfce4-smartbookmark-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-smartbookmark-plugin-0.5.0.tar.bz2 280988 BLAKE2B 783d495aae351454abf1a3d9bd43c0656baf7ff94bf3015ad300a103cd17eccfdae13385b025d293bd9d7a65b37c0a19aebf3cbca8276ce36d1e41287359d62c SHA512 0514a1159cb5218af73d28897a218c369a64b9c3a7c286c0bf45ad404773ccaa49af5c8b0492e38f56f8089a2ec79b0434de93388d960b993ad67cecef5315cc
+DIST xfce4-smartbookmark-plugin-0.5.1.tar.bz2 302735 BLAKE2B 3d80b78cefda5bd501578ac2b74734ac4e21f220b200239e6cd530c573b1e6b3f7e39e041d8def52bfb075cc8c584e09bc6c9249d3910a5bd98fa9d3d4cf82a2 SHA512 fb11d890f11751fd1b6ddd4ac351acde5a8b57cd67c0951ba655d762086be01527fbec59a2b4b7a191a1dcd1d4744929c8cad2b9ab30c83f3341e2ba06dd2596
EBUILD xfce4-smartbookmark-plugin-0.5.0.ebuild 1095 BLAKE2B af46d9c7dcbc587399b55f84a68fb11fc2b815fb9bc30b3a3606d562aae1eec2ac06b5120a9a4c010ed8a0323b5b19589050f1f463be127e3be9cfebdbe00926 SHA512 e3fd4c38a6e3742af80e09c857dc37c059e6b14126a2d865f54e7b188754846ae2a29512c1af8da6ecb37b8b5d012b765da9633857ca60ab9854902fb0b4a06e
+EBUILD xfce4-smartbookmark-plugin-0.5.1.ebuild 890 BLAKE2B f2759b937cb8b06e9f621356e168712fc10a8b9ec9c54b043bc2cf03759fc23b83a8d85e01a2b992d0c10521d26e0dbb526f042b7dd423189c8f73c3bd9db093 SHA512 5a8a725e1f47045b345c51441a7175641f11e0b7398e325e861adf432cc1eeccbbe734432d53231326f4ff982fa6088592212093223d5b84adfd8c8e342ae08d
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.1.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.1.ebuild
new file mode 100644
index 000000000000..5ae904c314fc
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+COMMON_DEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ # substitute default bugtracker
+ sed -i -e '/bugs/s:bugs\.debian:bugs.gentoo:' src/smartbookmark.c || die
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}