summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-smartbookmark-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
commit721e451ec418e1712f6962404e111f0ebd487389 (patch)
treeaab5b35236af464349c2522312c63b664273465c /xfce-extra/xfce4-smartbookmark-plugin
parente80134587e8d959a88dba7dd3784895372e205c8 (diff)
gentoo auto-resync : 27:12:2024 - 06:30:34
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.3.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/Manifest b/xfce-extra/xfce4-smartbookmark-plugin/Manifest
index 949c6183f86e..77bc9d4b74cb 100644
--- a/xfce-extra/xfce4-smartbookmark-plugin/Manifest
+++ b/xfce-extra/xfce4-smartbookmark-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-smartbookmark-plugin-0.5.2.tar.bz2 331765 BLAKE2B 00985170c8313b422747ae287d10c4fad6953ae1591d8f666d4beb4cf5323e3e020809f34da5228322ed396f33d43ce4608964f085724a3fcba8fc0cd2114b16 SHA512 56c5b4d366826de0b25f5665875f15d950a04ead7a3b5a7e546f27880363d47f3a1bba2c02e1f8ffd08b28cc4d4466d648740efda86ee8f378e0f8e721582b5f
+DIST xfce4-smartbookmark-plugin-0.5.3.tar.bz2 396301 BLAKE2B 93c3c19304b771710b8a0c292dc5064d20d1fe082392a4c4ad1024cee5c66ed135b3feb5581fa4a795a7a73ff8ae49d91e8ab091f45b7e43335e66f61b4554a3 SHA512 bb88d2ab7c0f4b792eb8fb899f4364dcee379ea90f5a3b64c3c149afc6e7e668a5820bc40003f2fdab51eced864bb3da76e1829080f4d58ae0e38e6d1bb56c0c
EBUILD xfce4-smartbookmark-plugin-0.5.2-r1.ebuild 914 BLAKE2B 639c0dd4aa7477856f7114d5b3b1a9a188a8fa854c1a4ba1d7e06dcca4d33c605d4d6cb18d89eee26728cfdd69120f04041432e33e4140291bb64496b60dade8 SHA512 ad0be1845f80dda7f387e163114aed55fae2f576b77b0f7ad956560912b53b2a3a7acc84de70d05be95f05b6fdbec57b612b36eaa6b1249e056575413a71ebe0
+EBUILD xfce4-smartbookmark-plugin-0.5.3.ebuild 950 BLAKE2B f407e2d1be266e2083cca108495249c57f81f35f32745b41bdd35bd4e0f4e3d8afdc5fd1d80f905915559c1869565675ee7a6fec166898708fdab549044a7e23 SHA512 5bf7be15ab948fde8711180bb263bb754527aa444e8302f47334e65d1b152ca44b914ee45657652fe8867358cbed61eeb3ac607970fe7e796ccc9046bab2603d
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.3.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.3.ebuild
new file mode 100644
index 000000000000..16f543e629d4
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-smartbookmark-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-smartbookmark-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # substitute default bugtracker
+ sed -i -e '/bugs/s:bugs\.debian:bugs.gentoo:' src/smartbookmark.c || die
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}