summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild')
-rw-r--r--xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild b/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild
new file mode 100644
index 000000000000..e2c81a70c9f3
--- /dev/null
+++ b/xfce-extra/xfce4-quicklauncher-plugin/xfce4-quicklauncher-plugin-1.9.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+#EAUTORECONF=yes
+inherit autotools xfconf
+
+DESCRIPTION="A quicklauncher plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-quicklauncher-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/xfce4-panel-4.8
+ >=xfce-base/libxfcegui4-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.8
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-X-XFCE-Module-Path.patch )
+
+ XFCONF=(
+ $(use_enable debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog TODO )
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^AC_INIT/s:quicklauncher_version():quicklauncher_version:' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ configure.ac || die #472522
+
+ # Prevent glib-gettextize from running wrt #423115
+ export AT_M4DIR=${EPREFIX}/usr/share/xfce4/dev-tools/m4macros
+ intltoolize --automake --copy --force
+ _elibtoolize --copy --force --install
+ eaclocal
+ eautoconf
+ eautoheader
+ eautomake
+
+ xfconf_src_prepare
+}