summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-pulseaudio-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /xfce-extra/xfce4-pulseaudio-plugin
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'xfce-extra/xfce4-pulseaudio-plugin')
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.2.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/Manifest b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
index 6db3da60ee83..daef9015a0b0 100644
--- a/xfce-extra/xfce4-pulseaudio-plugin/Manifest
+++ b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-pulseaudio-plugin-0.4.1.tar.bz2 391791 BLAKE2B 038eedbecbc6ba4845f1be86938aa57165f55e1d287f914deea998383fad5a019d1ca7500c7366d76692c1b59cf87214e2057833786318cb69c326eea2a69ea4 SHA512 e7b778c78ede9ad62afaa379941ce03636a79dd000e40e748079d3e0f3c71f2e68e32cf85e527be4e1192074652714db4b7c5707b727066198c2ea43184a71cc
+DIST xfce4-pulseaudio-plugin-0.4.2.tar.bz2 428504 BLAKE2B dd8c855e75aaee060df1e7abb2f8b835f1a630ce8b45b28c407c48f52071a51729e0bf8c645d5f68f968f12a45dea272d03ee69f4554009421a1a075a8fb8d2c SHA512 94184fe7379a7f1763d606fe3c45186767a43180329b43c8cba04b76ae5e1b2249531fc1fb6304da9bb03e7475ad65f861341253ead530d9a945165b4eb9e46e
EBUILD xfce4-pulseaudio-plugin-0.4.1.ebuild 1466 BLAKE2B 4b1111a9c7d31be46358135aef0d864b5c3c8e07435b956627cc5d0427d64ad086bb96acd7b765f29a060532f86f5f5cb8498bb148944f36c1106e45603c9f2b SHA512 d5f08999601dde100aac0a8523a999d5cfcb90348c702d4c00380e4fcd6c8245afa7897737f89173e8b1a29df520ca218b7465a2ebeb51435b1cd60501a6d55c
+EBUILD xfce4-pulseaudio-plugin-0.4.2.ebuild 1460 BLAKE2B f93479783e1e6ac283a291276b8397069bda9b27a22df83fac00a653346f6362868f34c45a835e0d17bad356842cfc38e86137c4349bed1debd81d3f25152a7a SHA512 15c4fc6d2cdcc782ad7510252322f6c8776090dc2907a71329e6a2d1926d9c905324566e15ea2e8d8c07b5c0df957d1372c3a48101d31df848e8c2baaf1be874
MISC metadata.xml 586 BLAKE2B 57900ad6e29515182780ef646d7861d3858150ab61861bf70c1a106221e20d7ca93f7bfd36e4337204a0abe32e515f60affae94342b6b76cdf6d34815e0130d8 SHA512 63bb2c2bd9a71f8d53f17cf5894039afb4592d8b5687e6daa4485a566464e3fe4f5ca45306409547f7d828488242fd760ddaa0587733f69067717ceffabba05e
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.2.ebuild b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.2.ebuild
new file mode 100644
index 000000000000..a492310fc30e
--- /dev/null
+++ b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for PulseAudio volume control"
+HOMEPAGE="https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug keybinder libnotify wnck"
+
+RDEPEND=">=dev-libs/glib-2.42.0:=
+ media-sound/pulseaudio:=
+ >=x11-libs/gtk+-3.20.0:3=
+ >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.9.0:=
+ >=xfce-base/xfce4-panel-4.11.0:=
+ >=xfce-base/xfconf-4.6.0:=
+ keybinder? ( dev-libs/keybinder:3= )
+ libnotify? ( x11-libs/libnotify:= )
+ wnck? ( x11-libs/libwnck:3= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable keybinder)
+ $(use_enable libnotify)
+ $(use_enable wnck)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ if ! has_version media-sound/pavucontrol; then
+ elog "For the 'audio mixer...' shortcut to work, you need to install"
+ elog "an external mixer application. Please either install:"
+ elog
+ elog " media-sound/pavucontrol"
+ elog
+ elog "or specify another application to use in the 'Properties' dialog."
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}