summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-places-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /xfce-extra/xfce4-places-plugin
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'xfce-extra/xfce4-places-plugin')
-rw-r--r--xfce-extra/xfce4-places-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/Manifest b/xfce-extra/xfce4-places-plugin/Manifest
index 1f8a1082a912..7b9f87f7b1cb 100644
--- a/xfce-extra/xfce4-places-plugin/Manifest
+++ b/xfce-extra/xfce4-places-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-places-plugin-1.7.0.tar.bz2 371395 BLAKE2B fe18391e0cabe06d9d63dfc86a829e35461858b5915d7331053dfabbc9bb689bba0a3cc05b7d7f6dced6e19aa6e32308ba052cca9416bbfb2f050768d3e86f5e SHA512 ae324a29584d7dc6beb4840bec7e4c5802e94c25512f449ab959c588c91f4030d895fe185dad87ab9442611e9fe01f8ccec82e8cb5153cf192d1124156be6bd3
+EBUILD xfce4-places-plugin-1.7.0-r1.ebuild 1018 BLAKE2B 186dad85b819f0926cc95e91228db711e644c8845ed1c68c38bb312f55128fb2ed5d0ff13db069f50606a07479febe27e5dc561df4bfcaa874c2793473a1a84b SHA512 e289fcfb44fd153f28b9d65be4ae30bed86529cea786fd1f9c490d12bfcec5a1cce4233df5e3f00f6bc4ac70877cea63c01d364cbc5aa397cfcce4e89bafacbb
EBUILD xfce4-places-plugin-1.7.0.ebuild 1008 BLAKE2B 69eab8b8f052d3f3c70f6b8db7fb2c1cf9bd612b3e553d884e543cbab152aaf615a81a072b4b9c3dda9a891ee2f3350c0df9a13619c707478a18a6b2547f5130 SHA512 c4124cd08e20808ba505ad95af806a70d3984c293f681efde9f0f21b07129046c6d08f45d53c2b608f1f5cd00a38f74e072d1369a11e0a8f6b2aa1f5546b1e6c
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..3730eebd90ec
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.8:=
+ >=xfce-base/xfconf-4.8:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}