summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-panel-profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /xfce-extra/xfce4-panel-profiles
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest2
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index a98903245d23..111c0d40c22a 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-panel-profiles-1.0.12.tar.bz2 83399 BLAKE2B 82f62b7472ae8e271a8c41151c2153e62f1589b868cd4a682f0e56acfa3aedcb6104b14ef99f776d09fe6ac854420905ce335c9d3d05d524570db70d847731d8 SHA512 cf308a1a9d68832a3b907787754791d6e8b227400d21a0bde2ed99d7afbb64c6137bbe4b7ab6ceb4c896a67ecbac29d41089c857d432467cbaba631a7ef77505
+DIST xfce4-panel-profiles-1.0.13.tar.bz2 86671 BLAKE2B 0bf2d39aa2d7d21a99a9a7245e5de9e717b628f0eded2736db70cc87c4f6e1e1d10aecdc6586c43c6355747e68a2ceb1920d5309bf38ede07c1167c590dc116f SHA512 648324e5dd95ab0a513829d7d816e2113ae677d9ad6ac9b01d73c6b4105b54d5e773150d5440ad35a37b4dc75478f40a24e0223decf940f3cf658241547ce75a
EBUILD xfce4-panel-profiles-1.0.12.ebuild 1010 BLAKE2B 926a69171925d0e35c8adcda9ecbb828e98d00561a6cc5e3776b522a149e8de950413c3058d2ff20991bce0a2e024e5c02b4d57f859888bcb766900b7202e23a SHA512 f001516b2c340c17dc2738b0e4e710085c19aa0c557276f182e81feae1bd3aa8386cb63961da2fb9d9972ba1ce8d31ea262452ffbac7217b8624257e8964291e
+EBUILD xfce4-panel-profiles-1.0.13.ebuild 1010 BLAKE2B 4443279f9e2abcdcf063206fc654db39e35bec1b89583e36a6fcf0b5f66a3224d6c4d22ec1a2c076278b7e41855c22c3a89b0bea52e5709c5b0cb7324ac3c687 SHA512 b444db0333f4acea6a32ee570f80b16b27650bfbbca71b92f8d341a616be894e94d2213ff5c994c22cea1bb254ed396dd001d04a91c30ead3afc2eaf193817b3
MISC metadata.xml 241 BLAKE2B 19a1f7371ba9451232b7795e806499d1de2aba44dc9864bf1c8c72f6074af18387f6091c891f84c402c70e52f8502bc7a9a937828d63991402d2f0d17b247782 SHA512 97a8057b496da7d18b75e0cec2f5de16f7f16187776c3d7134ade6b0be2539c5f0e8de7ce43c2a4fc342ca9c3dd83a74c194a506ad28221c260dfa8a4eadb1e8
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
new file mode 100644
index 000000000000..27462fad6085
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
+SRC_URI="https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="${PYTHON_DEPS}"
+RDEPEND="${BDEPEND}
+ dev-libs/gobject-introspection
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ xfce-base/libxfce4ui[introspection]
+ xfce-base/xfce4-panel"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --python="${EPYTHON}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}