summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-panel-profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /xfce-extra/xfce4-panel-profiles
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest2
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index 608a6f50622e..f8d606bfbb42 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-panel-profiles-1.0.8.tar.bz2 40074 BLAKE2B 620e74a6c5a7316e82bda0ad217abc9868685ee9fee6857c4e8aa35002f78f938a754ce709e56466ad648ae4637144d3e90d909e5d9e6865c5e519db75c4da8e SHA512 2d7980a79250414cc4611ccf573c2a3ee5eb510cf3ef6c32035ba23197eee1fded2e158cb50714dd935070916b07b3f33db02570f3d46a598144b4a2d3979ff4
+DIST xfce4-panel-profiles-1.0.9.tar.bz2 58886 BLAKE2B 3711bfdad68701af833e8ffcb8ada151b1120168193d8508d14dcbb3eabdd5eeb9f0b3b5ecad3c17e5e3afa1b42e73e72340b8ea2fcf9efa5235415384a49018 SHA512 a9b381d357482582210e153fdf1ced8055847ace0507dafc29fc952070fc4fe8fd34aff62342f442ec7045cfe87550c56ccf5d78c0f0a7de7ed64e4c303aab45
EBUILD xfce4-panel-profiles-1.0.8.ebuild 903 BLAKE2B 24b9c21451ce442df55d73999777d7109b119731918507ce5dc468069591886e7f77b406ef7097dac4f97dc610f41e4d5d8bd6bf78180696189b2e335b69f5e0 SHA512 6f531a448cdb78af0ce782244c65df9cdf1879cdae4335cbb3c0a5117d2775f95e5cbeea0e2651cfec461e47d3e9f0f58862e7583d3c80a2cc2747e20eac7623
+EBUILD xfce4-panel-profiles-1.0.9.ebuild 903 BLAKE2B 24b9c21451ce442df55d73999777d7109b119731918507ce5dc468069591886e7f77b406ef7097dac4f97dc610f41e4d5d8bd6bf78180696189b2e335b69f5e0 SHA512 6f531a448cdb78af0ce782244c65df9cdf1879cdae4335cbb3c0a5117d2775f95e5cbeea0e2651cfec461e47d3e9f0f58862e7583d3c80a2cc2747e20eac7623
MISC metadata.xml 240 BLAKE2B f2b1d74c53614dbfcc23494ddeeeb4726d3ebe22d0145658ac68fceb568b6f5f1d97cc59f17cd5a301e3cdabff03a4e5c48ba32a68577e0029c72eb348f13afe SHA512 c2cb083e77cc0a28c202c630546b0db2f37996e3125f0a6c9ead8ae5f819f910371ba237c59c09b7b7b83c417f1514f0e89a9b1c784bd282f60c377b0db020cd
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild
new file mode 100644
index 000000000000..7be1dfb541be
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit python-single-r1
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
+SRC_URI="https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ xfce-base/xfce4-panel"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure --prefix="${EPREFIX}/usr" --python="${EPYTHON}" || die
+}
+
+src_install() {
+ default
+
+ # the default gets it right
+ rm -r "${ED}"/usr/share/doc/xfce4-panel-profiles || die
+}