summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-panel-profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
commit721e451ec418e1712f6962404e111f0ebd487389 (patch)
treeaab5b35236af464349c2522312c63b664273465c /xfce-extra/xfce4-panel-profiles
parente80134587e8d959a88dba7dd3784895372e205c8 (diff)
gentoo auto-resync : 27:12:2024 - 06:30:34
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest2
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index 26b62a4b437f..6339cb760dec 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-panel-profiles-1.0.14.tar.bz2 101521 BLAKE2B 197ebba356e8d7661779531147b08454762a9b61beebd2323bc9e88b26381952c2caa58c6fb110680a5038fc19422852722d72dfde09addb68ec9424ecf16a23 SHA512 e316e9d4f0d27b16ce83a50adfe1a3fe2102b7f5c3ed9e9ceebf5968e265064b4d4ade1e0dbd84180758a9c1fa72d8df1fb4d06a631d07956ea8add0f66da984
+DIST xfce4-panel-profiles-1.0.15.tar.bz2 121102 BLAKE2B 7a5a1ba1e3ca565110f3fd962330f176d0e914f3b9154bf95bdbdb3d8b650bbe764751d1d745b601005ae1a52f85bae8f7db8467ff7ae93beb5d012296d860fe SHA512 cf836c318985619f4b74eca3cd54a91c8b6df5758395ae043272eb6056e551e7ecaefb57fc32b7c46d0082336cd44bae5aae95177440210cc6e446835b70b3f1
EBUILD xfce4-panel-profiles-1.0.14.ebuild 1070 BLAKE2B 38161157b1d14ffa6e2a011f360e6dcfc0c11a9ba75c68bd8d1fe48db7caaa1941ce3c1200cdca80e4907a4b0f19b27d12e621493436d5be6d27c3ec37954e3b SHA512 109fce85e27fc4541ad1d9f4b26a57bb2f1a18ab61e273adfbf25c76a1852ad58dbce49a2cf29268d788ac0a4f4f011b421f1b410be622c13b3bdecf480520dc
+EBUILD xfce4-panel-profiles-1.0.15.ebuild 1070 BLAKE2B 7801f76a634a7a7cf0f44b99694235dad214d4272980aee36676ffac43b920ede82d87046d3e04ea3699447a28a8f87ce9e1146dd7f7f275b036303c5fe576d6 SHA512 f1cf7425676dbf936a01f90ffb8e0542b2ad3d636c2837c03f5871763a4e6287b44ddcc681afbd4d0292a779600270056f8f323329b52ed39fef62ec8d9c7a9a
MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild
new file mode 100644
index 000000000000..cb66b48f35e9
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-panel-profiles/start
+ https://gitlab.xfce.org/apps/xfce4-panel-profiles/
+"
+SRC_URI="
+ https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${BDEPEND}
+ dev-libs/gobject-introspection
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ xfce-base/libxfce4ui[introspection]
+ xfce-base/xfce4-panel
+"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --python="${EPYTHON}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}