summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-panel-profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /xfce-extra/xfce4-panel-profiles
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest4
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild41
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild4
3 files changed, 46 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index d5de96f05503..2b88c7feef83 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,3 +1,5 @@
+DIST xfce4-panel-profiles-1.0.10.tar.bz2 62196 BLAKE2B 205469ab841843395429605660864a4d9496dde942ca5c8a587f32bc7143c7076f362ea0f9a488f20df3ce8ee357c4b236d3077ac07497673b3214d8fa02c20e SHA512 efd59d585cc916cfc9d87961a58f05dad754a70f1971d9c49a071e20b96bb28e6bd5fa13508430e5c0f15976db7c438d2c68e0ae5936563388fbbe02fffdb50a
DIST xfce4-panel-profiles-1.0.9.tar.bz2 58886 BLAKE2B 3711bfdad68701af833e8ffcb8ada151b1120168193d8508d14dcbb3eabdd5eeb9f0b3b5ecad3c17e5e3afa1b42e73e72340b8ea2fcf9efa5235415384a49018 SHA512 a9b381d357482582210e153fdf1ced8055847ace0507dafc29fc952070fc4fe8fd34aff62342f442ec7045cfe87550c56ccf5d78c0f0a7de7ed64e4c303aab45
-EBUILD xfce4-panel-profiles-1.0.9.ebuild 903 BLAKE2B 24b9c21451ce442df55d73999777d7109b119731918507ce5dc468069591886e7f77b406ef7097dac4f97dc610f41e4d5d8bd6bf78180696189b2e335b69f5e0 SHA512 6f531a448cdb78af0ce782244c65df9cdf1879cdae4335cbb3c0a5117d2775f95e5cbeea0e2651cfec461e47d3e9f0f58862e7583d3c80a2cc2747e20eac7623
+EBUILD xfce4-panel-profiles-1.0.10.ebuild 983 BLAKE2B 9b8051a373419a5f7b8956e65f049605a646ce3f5a1ecd27d3c2543bfe0ebeeb80555f06ce981cca7afa7cd019a9ee7f6020fe53f7d6c66546c0c7d2fda90e90 SHA512 d9d7d6e188821f65a603f51b59c4b8808fdc9ddb6717f834533124a3108620f6b63be8707b04a8738891ee1ca6bce322f18e013d2c132d68b86f041066853426
+EBUILD xfce4-panel-profiles-1.0.9.ebuild 901 BLAKE2B b0c65b267bb5b134a30c84420779fe073f5ab3dacda8ece0df87e4eda9e92bb3a8690da9f096fb761acb487a831ef13beecb129e9bd1f619e9f19ed496584291 SHA512 635bc6d6679751ce29cb22bfc4842b1a373aa75543a0c41af69ed5756dbfbb257456440bf0e9515e7cf30d6376e2bbf1c33f8939ac7a261866bec2c3b617f676
MISC metadata.xml 241 BLAKE2B 19a1f7371ba9451232b7795e806499d1de2aba44dc9864bf1c8c72f6074af18387f6091c891f84c402c70e52f8502bc7a9a937828d63991402d2f0d17b247782 SHA512 97a8057b496da7d18b75e0cec2f5de16f7f16187776c3d7134ade6b0be2539c5f0e8de7ce43c2a4fc342ca9c3dd83a74c194a506ad28221c260dfa8a4eadb1e8
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild
new file mode 100644
index 000000000000..be439f96939e
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
+SRC_URI="https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ xfce-base/xfce4-panel"
+
+src_prepare() {
+ default
+ sed -i -e '/install/s:.gz::' Makefile.in.in || die
+}
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure --prefix="${EPREFIX}/usr" --python="${EPYTHON}" || die
+}
+
+src_install() {
+ default
+
+ # the default gets it right
+ rm -r "${ED}"/usr/share/doc/xfce4-panel-profiles || die
+}
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild
index 7be1dfb541be..8c04fb6c2c5b 100644
--- a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
inherit python-single-r1
DESCRIPTION="Simple application to manage Xfce panel layouts"