summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-panel-profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /xfce-extra/xfce4-panel-profiles
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest2
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.12.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index 22aa1e90508b..f465c5d43d1a 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-panel-profiles-1.0.10.tar.bz2 62196 BLAKE2B 205469ab841843395429605660864a4d9496dde942ca5c8a587f32bc7143c7076f362ea0f9a488f20df3ce8ee357c4b236d3077ac07497673b3214d8fa02c20e SHA512 efd59d585cc916cfc9d87961a58f05dad754a70f1971d9c49a071e20b96bb28e6bd5fa13508430e5c0f15976db7c438d2c68e0ae5936563388fbbe02fffdb50a
+DIST xfce4-panel-profiles-1.0.12.tar.bz2 83399 BLAKE2B 82f62b7472ae8e271a8c41151c2153e62f1589b868cd4a682f0e56acfa3aedcb6104b14ef99f776d09fe6ac854420905ce335c9d3d05d524570db70d847731d8 SHA512 cf308a1a9d68832a3b907787754791d6e8b227400d21a0bde2ed99d7afbb64c6137bbe4b7ab6ceb4c896a67ecbac29d41089c857d432467cbaba631a7ef77505
EBUILD xfce4-panel-profiles-1.0.10.ebuild 1019 BLAKE2B b1aaf02cff0dacb43a29effaac74a9d3255ad389888ba976a2428b514fb74e47eb5852ef18a15ba159a5d6b2ab3f754e0bb0994c38009ed17659262468ca2251 SHA512 99cc8e04abce0ea186d06f32680031a270a1d7ac26096694de6d73d781b743b04b496d512371fe1cb595149195c8dd870b0afe0e4e4b7889aa8b57f312c75b7e
+EBUILD xfce4-panel-profiles-1.0.12.ebuild 1010 BLAKE2B 4cb64dd71d7b868e8a7e8a76b5944a528d097df430d527f75cc12ba7569c0331d56c1456ad14507540bf7b7bfd58e173a183ef763514fcd2baccab6b0935b620 SHA512 3714c814efb40bea39a5e5523e95ae92778d50608e0d285423dc1b4f2346a9c48468170585fa6d6c52ac033f246d57385de4a7357cc30ab572a519934aea308a
MISC metadata.xml 241 BLAKE2B 19a1f7371ba9451232b7795e806499d1de2aba44dc9864bf1c8c72f6074af18387f6091c891f84c402c70e52f8502bc7a9a937828d63991402d2f0d17b247782 SHA512 97a8057b496da7d18b75e0cec2f5de16f7f16187776c3d7134ade6b0be2539c5f0e8de7ce43c2a4fc342ca9c3dd83a74c194a506ad28221c260dfa8a4eadb1e8
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.12.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.12.ebuild
new file mode 100644
index 000000000000..3e69af3e8079
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
+SRC_URI="https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="${PYTHON_DEPS}"
+RDEPEND="${BDEPEND}
+ dev-libs/gobject-introspection
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ xfce-base/libxfce4ui[introspection]
+ xfce-base/xfce4-panel"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --python="${EPYTHON}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}