summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-notifyd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
commit924750a8c767b278c9870be5dcfedced436f1276 (patch)
treed5c93de95fb5c2fa090e76fd12c1535698005868 /xfce-extra/xfce4-notifyd
parenta4d4c6a7cf31d8d3248101dbfd654cdc416902ac (diff)
gentoo auto-resync : 03:11:2022 - 21:12:43
Diffstat (limited to 'xfce-extra/xfce4-notifyd')
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest3
-rw-r--r--xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch27
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4-r1.ebuild (renamed from xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild)9
3 files changed, 37 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index 78e99f10c670..32918b865cb6 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1,3 +1,4 @@
+AUX xfce4-notifyd-0.6.4-appinfo-crash.patch 978 BLAKE2B e0b58f01baae9b3eb951d7a7eb37831adbb9c5278ffbbee5a56dc3d99d3496925a1ef7865146954d0749a83579ba5d5c6a37cacfdbafdf2df40a844ee6413fcd SHA512 07bcd4ef0841a7a21940dcde4eb3b3098442aeff4bc4b21b1397481ac0974a259992025f2d0606e9bdbf54b1d02cc9eae96cd0722f8f0ac0c80485bc30700e0f
DIST xfce4-notifyd-0.6.4.tar.bz2 554776 BLAKE2B f594ee8a841e4074592a6377e79fde8dd89574620a433a9813f4ad106d712361e941b443de481cb9d140a47e7b1b4753116b4f949c39b6834926f0708877fb6e SHA512 644e2e49092892e386a9f82edc6ab3b2b59ba67617d9217fb43dd3cf74ae5cfc9b9bea6ed0fab4c4440eca68613aa996d9f8dc73deb1f60926217b7db18cc73b
-EBUILD xfce4-notifyd-0.6.4.ebuild 907 BLAKE2B 659b894f89c189270f7334022ae38ae18c773e6fface8db0bca83326b25e869ccd01ea3ee785a2c4964434e7a2ed1930b39d387e02c04230b79241fc56f12f3a SHA512 617d342fb6616a300bca39d8df8f9e629ee67415ff9039921d00d6b54380a13e8e71402ecd892a3d4fe7a85557d2cd87fc1032e682035bdf1dba4c69df8e3529
+EBUILD xfce4-notifyd-0.6.4-r1.ebuild 988 BLAKE2B e89924cf3f0f80b541f90feb60568c731711c833fee9244b4b9e57dda9a5e33d6fe9b8b2c731f9b16777c1b1cc9ab739ed11f82628330d2d7205c7fa557bef1e SHA512 31ad32c565407ee3dc2a86b10e10a10b14a70984079c35c9cfa9a6b65489c3703df4ec96df136f328267476e401eb66c5ffafc6f7c1629d28fc39f2e2bde7127
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch b/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch
new file mode 100644
index 000000000000..5ca1cbda8e53
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch
@@ -0,0 +1,27 @@
+From ddf469fe567f1c2f17013f3baa9bd3721cdd32a5 Mon Sep 17 00:00:00 2001
+From: Guido Falsi <mad@madpilot.net>
+Date: Fri, 2 Sep 2022 21:24:34 +0200
+Subject: [PATCH] Fix segfault crash.
+
+---
+ common/xfce-notify-log.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/common/xfce-notify-log.c b/common/xfce-notify-log.c
+index d42dc1e..7ccfd42 100644
+--- a/common/xfce-notify-log.c
++++ b/common/xfce-notify-log.c
+@@ -149,7 +149,9 @@ notify_get_from_desktop_file (const gchar *desktop_file, const gchar *key)
+
+ match = matches[0];
+ appinfo = g_desktop_app_info_new (match[0]);
+- value = notify_read_from_desktop_file (g_desktop_app_info_get_filename (appinfo), key);
++ if (appinfo != NULL) {
++ value = notify_read_from_desktop_file (g_desktop_app_info_get_filename (appinfo), key);
++ }
+
+ for (gchar ***p = matches; *p != NULL; p++)
+ g_strfreev (*p);
+--
+GitLab
+
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4-r1.ebuild
index 103fa082ba4b..4d510c7de30a 100644
--- a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4-r1.ebuild
@@ -6,7 +6,10 @@ EAPI=8
inherit xdg-utils
DESCRIPTION="Notification daemon for the Xfce desktop environment"
-HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-notifyd"
+HOMEPAGE="
+ https://docs.xfce.org/apps/notifyd/start
+ https://gitlab.xfce.org/apps/xfce4-notifyd/
+"
SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
@@ -32,6 +35,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-appinfo-crash.patch
+)
+
src_install() {
default
find "${D}" -name '*.la' -delete || die