summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-notes-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /xfce-extra/xfce4-notes-plugin
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'xfce-extra/xfce4-notes-plugin')
-rw-r--r--xfce-extra/xfce4-notes-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notes-plugin/Manifest b/xfce-extra/xfce4-notes-plugin/Manifest
index f02159f2879f..7e865c13063d 100644
--- a/xfce-extra/xfce4-notes-plugin/Manifest
+++ b/xfce-extra/xfce4-notes-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-notes-plugin-1.8.1.tar.bz2 479652 BLAKE2B ec23b362627b8bbfdf7dae69aa3217dd902f175b1899ffa07bcbcd17a34acd68ccb5c0acab65fe88a892f5a2c4e6ca7f9f6cc5ed9526a77028679a31bded455b SHA512 3e3f2513aaa5d26880d21ba31458aa8b79c1e01cac47141513d61002df9535e52ca2c14a8da6cddd54fcab3bcda6199c636cce045cea9bd4548f5fc763e069f3
+EBUILD xfce4-notes-plugin-1.8.1-r1.ebuild 889 BLAKE2B caed857cecbab6610126fc2a8fdbceb447c7113c9f1729ea327f0ce0b28c72d91f8fdce8d163d94c08f3d102dc231dcad8ea7a0d27a10babe744b7025b0f3da2 SHA512 788db77d077a4af46524d2510a989ae5bb13cb58a567bb703c6b9450e71fcedaa602d8de0a9de439a61f712deb08a922c94071244e425c0e2126a35a7ad77164
EBUILD xfce4-notes-plugin-1.8.1.ebuild 821 BLAKE2B 3f6b0cf3541d488ededb646b5acb0f0e45586813669ca7b261105e38e91688b1f0b5c01e19dc5d126ab83a6a25eb967c2e0bd5230f0252858907e1c0639f2ba4 SHA512 53700d951945c799bc98e8108fca5dc3ed95d77084a6258afc013bdf640b23aad41af8e0c3165d95d7f382396e7d851edf9309eb27af55a0d63a5a2defcf1766
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r1.ebuild b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..359ec0504512
--- /dev/null
+++ b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 panel sticky notes plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10:=
+ >=xfce-base/xfconf-4.10:=
+ dev-libs/libunique:1="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}