summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild')
-rw-r--r--xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild b/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild
new file mode 100644
index 000000000000..835a3b98b5e6
--- /dev/null
+++ b/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Music Player Daemon (mpd) panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-mpc-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+libmpd"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.13.5:=
+ libmpd? ( media-libs/libmpd:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable libmpd)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}