summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-mailwatch-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /xfce-extra/xfce4-mailwatch-plugin
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/Manifest b/xfce-extra/xfce4-mailwatch-plugin/Manifest
index 3d4262c771bd..ede97cbf0468 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/Manifest
+++ b/xfce-extra/xfce4-mailwatch-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-mailwatch-plugin-1.2.0.tar.bz2 509649 BLAKE2B 7749914cf4e8ca34e27c63033e84718c4bc8d9da11ca9f6487bf9291c145f5b062d6b7b07d03d2eb273d0e88b96946641721f6f24dd19c19db9f923e9b33ff53 SHA512 6f5128b2341ab275427e02b1ef063cb2fdcf4027f5c47cfc0ed26086462eb0e9f7353441ea1b9380b91a892414934203b781445f604d67200786e3dd85183a83
+DIST xfce4-mailwatch-plugin-1.3.0.tar.bz2 551687 BLAKE2B 3ec841c32df059a2be99ad21c706be794d97c493e9ae1c1be5ec9006c45df51a766c8c89ef9f2941f6c411c18bfd5d01e8a510acfc4233cb349e1528346d0617 SHA512 07d4e4cc2f7d299a142d9e9b307c2797892a5febd8451d5291cb9574be0bd5daba677ee893fea3af49b6a8acbfb827ae0125ba11014df37b6c68a2734ecde11b
EBUILD xfce4-mailwatch-plugin-1.2.0-r6.ebuild 1079 BLAKE2B a1491670b95724aed82f6da36119b7f35b0e516db4417bc70ec874f8809c621e9a0a7394189ebc9a0cb24e93c7b3ebd44f80cab8fe4b84c7eaef64d142077a2d SHA512 0e1391c335a22cfd4abdf54c540ca8360cb91d3cff98100866b75fd570666146968143de84dc1415cefcce687a7a4b4af6b52edbb8e91ce5ce843eee31aafcaa
+EBUILD xfce4-mailwatch-plugin-1.3.0.ebuild 1009 BLAKE2B 035ef3280ff2182f6e2d4fdc45898aae376216d7409cf87aa3ed7e96af42915c4061966011a15341a51ad70cbce2154e964c15f7a918047670f3b9fa3d05d543 SHA512 fdd6802975d5ef60153e4356b79adc32eb50020e4f42268c1354e6de12b56d57929d212a39b2a0a9778fe4b949cae464cb30762969264fee25065ac17a972160
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild
new file mode 100644
index 000000000000..f652fef4599c
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="https://spuriousinterrupt.org/projects/xfce4-mailwatch-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="ipv6 ssl"
+
+RDEPEND=">=dev-libs/glib-2.42:=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ ssl? ( >=net-libs/gnutls-2:= )
+"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf $(use_enable ssl) $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}