summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-mailwatch-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
commit76cba73c47c8694e74377004634daca18f2d9c08 (patch)
tree468603ebdc189bcfae77696162761b3be936baea /xfce-extra/xfce4-mailwatch-plugin
parent6957f5c65b02bba533954eabc0b62f5de36be206 (diff)
gentoo resync : 14.04.2018
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/Manifest b/xfce-extra/xfce4-mailwatch-plugin/Manifest
index 5c516810d3eb..3f01e4c96fed 100644
--- a/xfce-extra/xfce4-mailwatch-plugin/Manifest
+++ b/xfce-extra/xfce4-mailwatch-plugin/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-mailwatch-plugin-1.2.0.tar.bz2 509649 BLAKE2B 7749914cf4e8ca34e27c63033e84718c4bc8d9da11ca9f6487bf9291c145f5b062d6b7b07d03d2eb273d0e88b96946641721f6f24dd19c19db9f923e9b33ff53 SHA512 6f5128b2341ab275427e02b1ef063cb2fdcf4027f5c47cfc0ed26086462eb0e9f7353441ea1b9380b91a892414934203b781445f604d67200786e3dd85183a83
+EBUILD xfce4-mailwatch-plugin-1.2.0-r1.ebuild 1058 BLAKE2B f2c03d34648d484dcb7ff47a127e68ec40e886ab6e71e76c1bd9549a66d46635b6024f9f4b76c3a0693c4067463207a5d3144263f12b683d4539f2dd42100801 SHA512 9d4eeb08dc4ef80f506c16fe1c270d3be2cfe4f897a2e407129c5afeae3702a6fef91abfb1da34c71ffeaaf7ddac48a578b58792c720c692c18e4405b9a03606
EBUILD xfce4-mailwatch-plugin-1.2.0.ebuild 970 BLAKE2B 5c4ae61618f95602eb92a8fc04af96cd151c6d0989ecf655ed8b7528ab96418cd31bf96b0bf466a66cdda47c0d737083e0769f4857c5469782defadcb42892b6 SHA512 533d87aa68ab75bf5320b7ccd350258f770682b2cedb2d1d99a2910e1ef655f2279d65a20067496eabe2f31e3ef5e5a33cca8693a29bed28d09469bc913f4246
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..0c70bc8952d1
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://spuriousinterrupt.org/projects/xfce4-mailwatch-plugin/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="ipv6 ssl"
+
+RDEPEND=">=dev-libs/glib-2:=
+ >=x11-libs/gtk+-2.18:2=
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.7.2
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10
+ ssl? (
+ dev-libs/libgcrypt:0=
+ >=net-libs/gnutls-2:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable ssl) $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}